"Could not locate SDK bin directory"

I have been trying to get this fixed for three days but nothing has been successful.

I paired my windows VS to a mac that has XCode 10, and VS on it. Mac can build and run IOS apps.
However, whenever I try to build from my Windows, paired with my mac, it gives me the same error:
"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(624,3): error : Could not locate SDK bin directory"

My Xcode is in "/Applications/Xcode.app" and in windows, I am pointing to the right locations (Tools>Options>Xamarin>IOS Settings>Apple SDK)

Is there a solution to my problem?


  • PierceBogganPierceBoggan USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Would you mind logging an issue via Help > Feedback > Report a Problem? This is the best way to report issues and ensures we have the diagnostic information we need to help resolve the issue for you.

  • I am also facing the same problem in Mac & unable to run the app on iOS Simulator. Getting the same error:-
    Error 624: Could not locate SDK bin directory

  • JakeAnsteyJakeAnstey USMember ✭✭

    I'm getting the same error after updating xCode. Still trying to fix this.

  • juangalfjuangalf Member
    edited September 2018

    Finally I've solved it: open your XCode and let it update everything. Then in you VS for Mac go to the menu "Visual Studio" -> "Check for Updates" and update your VS. Everything worked perfectly for me and now I have the new Emulators: iPhone XS, iPhone XS Max, and iPhone XR.
    Thanks to this Stack Overflow answer for giving me some great ideas: /q/52398460/2816119

  • Monika_MaliMonika_Mali Member ✭✭

    I am also facing the same problem unable to run the app on iOS Simulator. but app is successfully run on device.
    Getting Error: 'Could not locate SDK bin directory' when run app on simulator.

  • puneetmahalipuneetmahali Member ✭✭
    edited September 2018

    @Monika_Mali You have two options one is same as @juangalf said need to update Xcode & VS then you can run on simulator. Second is you can download Xcode previous version means Xcode11 or 11.x. After that you need to change the SDK path in your VS, that's also Work.

  • Monika_MaliMonika_Mali Member ✭✭

    @puneetmahali Already tried.... But still facing same issue.

  • @Monika_Mali Can you please let me know which Xcode version you used(except from 10.0). Also need to change the Xcode.app path in VS.
    from here you can download the Xcode - Link

  • Monika_MaliMonika_Mali Member ✭✭

    @puneetmahali My Xcode version is 10.0 and use default Xcode path in VS on Windows.

  • puneetmahalipuneetmahali Member ✭✭
    edited September 2018

    Yes, this is the bug may be in Xcode or VS because default Xcode path is not reading the Xcode.app. That's why I am saying download the 2 Xcode on your machine or downgrade your Xcode10.0 to 9.x until the bug will not fixing.

  • gesturegesture Member
    edited September 2018

    This is an issue with Xcode 10.0, try installing Xcode version 9.4( Inside application) and then go to tools->SDK manager->SDK location->select apple-> provide the installed Xcode location path which should be like application/newXcode.app.

  • Monika_MaliMonika_Mali Member ✭✭

    Thanks @puneetmahali and @gesture

  • rahulrahul Member ✭✭

    I am facing the same issue. I updated Xcode to version 10.0, and after that updated VS also but still the same error : Could not locate SDK bin directory. The sdk location(Tools>Options>Xamarin>IOS Settings>Apple SDK) is also correct.
    I am able to run my code in xcode on simultaor but the same wont work in VS.
    Do I need to rollback my Xcode to fix the error or there is some other way.

  • puneetmahalipuneetmahali Member ✭✭
    edited September 2018

    @rahul Still no solution, I think need to wait for new update of Xcode10.1. In the meantime you need to downgrade your Xcode or you can download one more Xcode(may be 9.x). If you want to use the 2nd Xcode then change your 2nd Xcode SDK path in the VS.

  • I guess the problem is Visual Studio doens't recognize the newest xCode it probably fails trying to match up with the latest version right? I already tested with Xcode10.1 beta version there also I got it the same problem.
    See More Discussion here

  • I have updated my Visual Studio now and it's working for me. Just update the Visual Studio(See the VS updated notes).

  • rahulrahul Member ✭✭

    @puneetmahali thanks as it is also working fine for me now after updating the VS as the previous version of VS was not compatible for Xcode 10.

  • @rahul Perfect.

  • IrgiIrgi USMember ✭✭

    Had the same Problem. Updated VS to 15.9.2 and it is fixed.

Sign In or Register to comment.