Only debugging every second time, have to cancel build every other time

ReppiksReppiks DKMember ✭✭

For some reason on both my laptop and desktop, both running VS 2017 15.9.0 Preview 1 (And before that build as well)

About every other time I press F5, nothing happens, and nothing will continue to happen until I go to Build -> Cancel Build

There is nothing in any of the output windows

Have also tried changing between Android Emulator, UWP and x86 or x64 targets

The only thing I can see happening is that little arrow going down in the box as shown on the screenshot, but that has zero tooltip, so not sure if its indicating that its downloading nuget packages

When it works it just looks normal

Anyone have a good suggestion of what to do? Its pretty annoying :(

Best Answer

Answers

  • VIVEKNEGIVIVEKNEGI USMember ✭✭✭

    Delete all bin and obj folder under your project then try to build again.

  • ericregnierericregnier Member ✭✭

    I have to do the same thing as well. Really annoying so I hope there is a long term fix for this.

  • I am also left with this problem. Although i am using visual studio 15.8.2 (Community and Enterprise). Its exactly as described here, first build does not nothing and hangs on a empty output window. Cancelling the build and then re running with debug fixes the issue. I've tried resetting all of my settings to no avail. Happened shorty after i upgraded

  • ReppiksReppiks DKMember ✭✭

    Well at least I am not alone, but such a wierd bug

  • ErikKrlErikKrl CZMember ✭✭
    edited September 2018

    I can confirm that too. It looks like it freezes on "Live code analysis".

    PS:
    I am a lecturer and I wanted to teach students Xamarin as I did last year, but yesterday I just gave up on Xamarin and I don't know if I want teach it anymore. Students need something that works out of the box, at least hello world application :( and it looks like that it is something that Microsoft and Xamarin can not offer anymore and there are some serious quality assurance problem there :(.

  • ReppiksReppiks DKMember ✭✭

    @ErikKrl said:
    Here is the temporary solution:

    You have to save manually the XAML file first before building the project or uncheck "Automatically check for missing packages during build in Visual Studio" under Tools | Options | NuGet Package Manager.

    Thanks! Hopefully a fix is implemented soon :)

  • GaryParkinGaryParkin USMember ✭✭

    I thought I was going nuts. There's no reason for the fail.
    I'm using VS 2017 V 15.9.7
    I unchecked NuGet and it still happens. I'm really hating Xamarin.

Sign In or Register to comment.