Forum Xamarin.iOS

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Build failure

MudMud USMember ✭✭
edited August 2018 in Xamarin.iOS

I have a Xamarin app up on the app store. I hadn't touched it for about a year and needed to make a minor update. Of course, OSX wanted me to updated everything, so I updated the OS to latest, updated Xcode to latest, and now my app doesn't build.

Because Xamarin abstracts everything away (good!), I've never had to actually learn to do development on a Mac (bad!), so I don't even know where to start with this error.

I've attached the full error. Can anyone take a look and give me a hint of what direction I should be looking?

Thanks!

Answers

  • MudMud USMember ✭✭

    Bump to get above massive spam attack:

  • MudMud USMember ✭✭

    My version was set to 8. I cranked it to max (11-something) and that had no effect. However, deleting LaunchScreen.storyboard fixed it. However, I have no idea why I had to do that, nor what effect it's going to have on my applications startup screen. But building with a broken startup screen is better than not building at all.

    However, now I can't run or debug the app. "Run Item" and "Start Debugging Item" are both disabled.

  • ColeXColeX Member, Xamarin Team Xamurai

    If Launch.storyboard is deleted from your project, the key value of XSLaunchImageAssets in info.plist is supposed to delete as well.

    After that , restart visual studio ,delete obj and bin under the application folder, and rebuild your project.

Sign In or Register to comment.