Forum Libraries, Components, and Plugins

AudioToolbox for iOS: JackServer Issue


I want to use the AudioToolbox for an iOS App and so, call that:
using AudioToolbox;
And later in the code, create an audio format as:
var audioFormat = new AudioStreamBasicDescription () {
SampleRate = 16000,
Format = AudioFormatType.LinearPCM,
FormatFlags = AudioFormatFlags.LinearPCMIsSignedInteger | AudioFormatFlags.LinearPCMIsPacked,
FramesPerPacket = 1,
ChannelsPerFrame = 1,
BitsPerChannel = 16,
BytesPerPacket = 2,
BytesPerFrame = 2,
Reserved = 0
But the next line creating the Audio Queue:
var AudioQueue = new InputAudioQueue (audioFormat);
generates the following error in the Simulator (iOS 11.4, iPhone 7plus):

Error loading /Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter: dlopen(/Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/HAL/JackRouter.plugin/Contents/MacOS/JackRouter: mach-o, but not built for iOS simulator

would you have any pointer on how to solve that?




  • BencolburgBencolburg Member ✭✭

    Had I pushed a bit more I could have avoided a maybe silly question.
    Anyway, I solved it by uninstalling jack from my mac.
    If like me you forgot that you installed that a long time ago, you can type jackd in a terminal to see if it is there.
    If it is, in your Application directory there should be a Jack directory in which you find the uninstall script.

    It solved my problem for the moment but it is a bit inconvenient if you need jack for other applications.
    So, if you have an other way of solving that I am interested as well.

Sign In or Register to comment.