Project is not compatible with MonoAndroid 8.1

I was just coding in my Xamarin.Forms project, and suddenly, this error appeared:

Project is not compatible with monoandroid81(MonoAndroid,Version=v8.1). Project TaskX.iOS supports: xamarinios10 (Xamarin.iOS,Version=v1.0)
I don´t really know what this means. Does anyone have a solution?

Best Answer

Answers

  • HkncoreHkncore ATMember ✭✭

    It seems like your projects targetversion is iOS and you are using some Android. This is weird

    Try to clean your solution and rebuilding it. If that doesnt work try restarting Visual Studio.

  • SzbestaSzbesta Member ✭✭✭

    @Hkncore said:
    It seems like your projects targetversion is iOS and you are using some Android. This is weird

    Try to clean your solution and rebuilding it. If that doesnt work try restarting Visual Studio.

    +1

  • SebGM2018SebGM2018 Member ✭✭
    > @Hkncore said:
    > It seems like your projects targetversion is iOS and you are using some Android. This is weird
    >
    > Try to clean your solution and rebuilding it. If that doesnt work try restarting Visual Studio.

    None Worked
  • JoeMankeJoeManke USMember ✭✭✭✭✭

    Did you accidentally add a reference between your Android and iOS projects?

  • SebGM2018SebGM2018 Member ✭✭
    > @JoeManke said:
    > Did you accidentally add a reference between your Android and iOS projects?

    Yes, But I already removed it and it stills
  • JoeMankeJoeManke USMember ✭✭✭✭✭

    Then you probably just need to clean harder. Close Visual Studio, delete your bin and obj folders, and try again.

  • RobertAuerRobertAuer USMember ✭✭

    I'm running into the same issue, I deleted all my bin and obj folders in the entire project - and I still get this error:

    NU1201: Project TLXMobile.Android is not compatible with xamarinios10 (Xamarin.iOS,Version=v1.0). Project TLXMobile.Android supports: monoandroid81 (MonoAndroid,Version=v8.1)

    Is this because of the change to OS 10? It seems to think that I'm working iOS 1 and not 10.

  • JoeMankeJoeManke USMember ✭✭✭✭✭

    That looks like you're trying to make your Android project reference your iOS project.

  • None of the suggestions worked for me. But I deleted every Nugget Package one by one cause I read that old nugget packages can cause this issue. Well I managed to solve the problem but my app doesnt work anymore. I had to delete Newtonsoft.Json. I hope someone can tell us why this Package doesnt work at the moment.

Sign In or Register to comment.