Some iOS simulators disappear when trying to select them

PhysikbuddhaPhysikbuddha DEMember ✭✭

I can't select some of the iOS simulators to test my app (Xamarin.iOS Native, Minimum iOS Version: 9.0).
They disappear as soon as I select any simulator from the list and reappear when I choose "Device" or "Xamarin Live Player".
Only old devices seem to be affected, like iPhone 4S, iPhone 5 or iPad 2. When I try to select one of these old ones, "iPhone 8 iOS 11.2" gets selected as fallback.

They work fine with another app (Xamarin Forms, Minimum iOS Version: 8.0).
I tried to lower the Min iOS Version back to 8.0 but that didn't work.

Attached a screenshot showing the list before and after choosing a simulator.
Note the missing entries.

Is this a bug? What am I doing wrong?
What more information may I provide to help?

Tagged:

Answers

  • JohnHJohnH GBMember ✭✭✭✭✭

    My guess is that your mac doesn't have those older simulators installed?

  • PhysikbuddhaPhysikbuddha DEMember ✭✭
    edited July 2018

    Like I said: they work perfectly fine with version 1.x of my app.
    I've been using Xamarin Forms for version 1.x and switched to Native for 2.x

    The simulator won't work with 2.x only.

  • PhysikbuddhaPhysikbuddha DEMember ✭✭

    Solution: The app did not support 32 bit.
    Don't try to change this behaviour by modifying UIRequiredDeviceCapabilities in the Info.plist file.

    Instead, right-click your iOS project, choose Properties/Options, go to the iOS Build section.
    Change the Supported Architectures from ARM64 to ARMv7 + ARM64 or ARMv7 + ARMv7s + ARM64 for iPhone|Debug and iPhone|Release.
    Change the Supported Architectures from x86_64 to i386 + x86_64 for iPhoneSimulator|Debug and iPhoneSimulator|Release.

Sign In or Register to comment.