Forum Xamarin.Android

Using real device as emulator

Hello everyone,

I tried to use a real deveice as an emulator,I follox the documentation here, but the Xamarin did not find my device(Onda, with Android 4.0.4) even I installed USB drivers.Would enyone help me.Thank you so much?


  • moljacmoljac HRBeta ✭✭✭

    Did You check Settings +/ Deveoper Options +/ USB debugging??

    If yes then You have problems with USB drivers. I had similar problems with my Galaxies

    • Gooogle Drivers did not help
    • downloading separate package (part of Kies - I did not want full Kies installation) did not help either
    • installing Kies and then uninstalling helped.

    So try finding USB drivers and/or some software like Kies, though I don't see something similar...

  • DaveCarsonDaveCarson GBUniversity ✭✭✭

    I had a similar problem with a Sony Xperia I was using as a test device. I had installed the Google USB drivers for the device but neither Visual Studio or Xamarin Studio could see it.

    In the end I installed the Sony PC Companion which must have provided the appropriate driver and the device appeared in the IDEs from then on.

    There are a number of 'universal' adb drivers and I've had mixed results with these. I think this one worked on one of my systems but not 100% sure without looking.

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    The issue is usually that some devices have specific ADB drivers that you need to install from the manufacture's website. Motorola, Samsung, etc. all provide these. The easiest way to know is to to Device Manager and see if it is showing up as an ADB device.

  • SebastianSeidel.9226SebastianSeidel.9226 DEInsider, University ✭✭✭✭

    Also helpful. Check if your device trusts your computer. The device will ask you the very first time.

  • moljacmoljac HRBeta ✭✭✭

    @JamesMontemagno: Just for the record with Samsung Galaxy drivers (as separate package) I did not manage to get it to work. After Kies installation it worked. Later on I deinstalled Kies (just for fun) and everything is still working, both for S2 and S3. Could be that Kies had some newer libraries/drivers in its bundle.

    Similar solution was for Xperia Z and Xperia S - installing PC Companion.

  • RojinRojin USMember

    Thank @DaveCarson installing Sony PC Companion worked for me too :smile:

Sign In or Register to comment.