Forum Xamarin Xamarin.Android

All references broken after moving project to another computer

CadenFarleyCadenFarley USMember ✭✭
edited June 2018 in Xamarin.Android

After moving computers, all the references are missing. I tried using NuGet package restore but it just said 0 packages to restore. I tried uninstalling and reinstalling all the packages. I tried updating the packages. Even packages that weren't installed before show up with the yellow triangle after being installed. I also tried manually adding the references by pointing to the .dll files but the references still show up with yellow triangles. Please help!

Thank you in advance.



  • robbitrobbit CNMember Xamurai

    Have you tried to delete the bin and obj folder and restart your vs?

  • izhangizhang USMember, Xamarin Team Xamurai

    You can also try deleting the packages folder in addition to the suggestions by robbit.

  • CadenFarleyCadenFarley USMember ✭✭

    I tried deleting packages, bin, and obj but still didn't work.

  • HarbHarb USMember ✭✭

    bump. I have the same problem. Whenever I reinstall any package it instantly shown as errored one - reference not found. Even if I explicitly give the reference path. Any clues?

  • ErhanAlankusErhanAlankus TRMember ✭✭

    I just encountered this issue.
    I moved my Xamarin.Forms solution to another folder, and the nuget packages broke.
    I deleted bin and obj folders, I tried cleaning and rebuilding the solution, they didn't work.

    For now I'll just start with a brand new solution since it was a new project, but it would have been pretty annoying if it was an old project.

Sign In or Register to comment.