Xamarin Forms Application build problem missing DLL

**Error ** : The "ResolveLibraryProjectImports" task failed unexpectedly.
System.IO.FileNotFoundException: Could not load assembly 'DummyApp, Version=0.0.0.0, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile?
File name: 'DummyApp.dll'
at Java.Interop.Tools.Cecil.DirectoryAssemblyResolver.Resolve(AssemblyNameReference reference, ReaderParameters parameters)
at Java.Interop.Tools.Cecil.DirectoryAssemblyResolver.Resolve(String fullName)
at Xamarin.Android.Tasks.ResolveLibraryProjectImports.Extract(DirectoryAssemblyResolver res, ICollection1 jars, ICollection1 resolvedResourceDirectories, ICollection1 resolvedAssetDirectories, ICollection1 resolvedEnvironments)
at Xamarin.Android.Tasks.ResolveLibraryProjectImports.Execute()
at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
at Microsoft.Build.BackEnd.TaskBuilder.d__26.MoveNext() DummyApp.Android C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets~~~~

**Error **: CS0006 Metadata file 'E:\Folder\DummyApp\DummyApp\DummyApp\DummyApp\bin\Debug\netstandard1.4\DummyApp.dll' could not be found DummyApp.iOS E:\Folder\DummyApp\DummyApp\DummyApp\DummyApp.iOS\CSC

Tagged:

Answers

  • BillyLiuBillyLiu Member, Xamarin Team Xamurai

    Hi, @SandeepSubbiah

    Please try to clean and rebuild the project, delete the bin, obj files and restart the VS.

  • I have the exact same error. I have tried these suggestions as well has updating packages and creating new projects, but still always stuck on this error. Any suggestions would be appreciated!

  • AaronQU89AaronQU89 Member

    The few times I have seen this, they have always been relieved by closing and reopening the solution. For one reason or another Xamarin Forms needs to be reloaded in order to flag syntax errors causing this error.

Sign In or Register to comment.