Emulator Android_Accelerated_x86 cannot be started. Runtime checks failed

RookRook USMember

I'm trying to run some example project from Xamarin University (XAM101) and I'm getting the following error:

Emulator Android_Accelerated_x86 cannot be started.
Runtime checks failed

I was able to run this project just fine a little over a week ago, now it won't run with the emulator.

It will deploy to my Samsung Galaxy 6S and run just fine.

Prior to this I was getting an error related to audio. I enabled Stereo Mix in the Recording tab of the Sound control panel and then started getting this new error.

I updated Visual Studio 2017 to 15.7.4 and updated things in the Android SDK and Tools.

Any help would be appreciated.

Here's the full output:

Starting runtime checks
Starting emulator Android_Accelerated_x86 ...
1>------ Build started: Project: XAM101.Android, Configuration: Debug Any CPU ------
C:\Program Files (x86)\Android\android-sdk\tools\emulator.EXE -partition-size 512 -no-boot-anim -avd Android_Accelerated_x86 -prop monodroid.avdname=Android_Accelerated_x86
HAX is working and emulator runs in fast virt mode.
Emulator Android_Accelerated_x86 cannot be started.
Runtime checks failed
1>  XAM101.Android -> D:\Users\Eric\OneDrive\Documents\Source\Xamarin University\XAM101\XAM101\XAM101.Android\bin\Debug\XAM101.Android.dll
1>  No way to resolve conflict between "mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" and "mscorlib, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e". Choosing "mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" arbitrarily.
2>Starting deploy Android_Accelerated_x86 ...
2>Starting emulator Android_Accelerated_x86 ...
2>C:\Program Files (x86)\Android\android-sdk\tools\emulator.EXE -partition-size 512 -no-boot-anim -avd Android_Accelerated_x86 -prop monodroid.avdname=Android_Accelerated_x86
2>HAX is working and emulator runs in fast virt mode.
2>Emulator Android_Accelerated_x86 cannot be started.
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

Posts

  • RookRook USMember

    I was able to get things working by going to the Android SDK Manager and in the Tools tab, expanding Android SDK Tools, and selecting Android SDK Tools 25.2.5.

    After doing this the Android emulator worked.

Sign In or Register to comment.