Is it deliberate that VS 2017 Community Edition forces AotAssemblies and EnableLLVM back to false?

SteveShaw.5557SteveShaw.5557 USMember ✭✭✭
edited June 2018 in Xamarin.Forms

I have a Xamarin Forms project I am building for Android.
Not having Enterprise license, I manually set the mentioned properties to true, as discussed in various posts.

Various UI actions involving project set these back to false:

  1. Loading solution while Release build is the active target.
  2. Opening project properties in GUI.
  3. Clean project or solution.

Is this a deliberate attempt to keep Community users from using these (normally Enterprise) features?

Here is my complete set of properties for this project:

  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
    <DebugSymbols>false</DebugSymbols>
    <Optimize>true</Optimize>
    <OutputPath>bin\Release</OutputPath>
    <ErrorReport>prompt</ErrorReport>
    <WarningLevel>4</WarningLevel>
    <ConsolePause>false</ConsolePause>
    <AllowUnsafeBlocks>true</AllowUnsafeBlocks>
    <DefineConstants>... some flags custom to our app ...</DefineConstants>
    <EmbedAssembliesIntoApk>true</EmbedAssembliesIntoApk>
    <Debugger>Xamarin</Debugger>
    <AndroidUseSharedRuntime>false</AndroidUseSharedRuntime>
    <AotAssemblies>true</AotAssemblies>
    <EnableLLVM>true</EnableLLVM>
    <BundleAssemblies>false</BundleAssemblies>
    <AndroidLinkMode>Full</AndroidLinkMode>
    <AndroidCreatePackagePerAbi>false</AndroidCreatePackagePerAbi>
    <AndroidLinkSkip>Exodus;Exodus.Framework</AndroidLinkSkip>
    <AndroidSupportedAbis>armeabi-v7a;x86</AndroidSupportedAbis>
  </PropertyGroup>

(Not running ProGuard or MultiDex, because I was testing whether AOT+LLVM caused any issues, before turning those on.)

Or perhaps these options now "do nothing" unless running Enterprise, so this resetting is just a side-effect of an absent feature?

Tagged:

Best Answer

Answers

Sign In or Register to comment.