Getting Android Apps Ready for Google Play’s Target API Level Requirements

JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

Getting Android Apps Ready for Google Play’s Target API Level Requirements

See blog here: https://blog.xamarin.com/android-apps-google-play-target-api-level-requirements/

Posts

  • ChristopherStephanChristopherStephan DEMember ✭✭
    edited September 2018

    Do you think that one should always update the targetFramework in the packages.config file when increasing the Android Target Framework version, too?

    For example, when updating Android Target Framework Version from version 6 to 8 one must update:

    package id="Toasts.Forms.Plugin" version="2.0.4" targetFramework="MonoAndroid60"

    to

    package id="Toasts.Forms.Plugin" version="3.3.2" targetFramework="monoandroid80" ?

    What are the potential risks when you do not do that?

  • calljeet_2001calljeet_2001 Member ✭✭
    edited October 2018

    James, this is a fantastic post kudos to you ! Our problem was that self signed root CA certs that were working before api level 26 suddenly stopped working. i did the following settings to get it to work again

    this line in the Android manifest to be changed to contain only the minSDKversion remove any other tags

    uses-sdk android:minSdkVersion="19"

    make sure that the Android manifest section under project properties looks like this

    Make sure that the application section under project properties looks like this

Sign In or Register to comment.