Xamarin.UITest on iPhoneSimulator: Failed to install DeviceAgent ExitCode: 1

Hi I am getting the following error when running my UITests on an iPhoneSimulator (iPhone 8 iOS11.4). My colleagues can run them no problem.

I would have posted in the Xamarin Test Cloud forum but it is read only now, so feel free to move into which ever one is most applicable.

I'm using following environment:

MacBook Pro (13-inch, 2017) macOS 10.13.5
Visual Studio for Mac Enterprise (Beta Channel) 7.6 Preview
Xamarin.UITest 2.2.4

SetUp : Xamarin.UITest.XDB.Exceptions.DeviceAgentException : Failed to install DeviceAgent

ExitCode: 1

        -c,--codesign-identity  <codesign-identifier> [OPTIONAL]    Identity used to codesign app bundle [device only]. Deprecated - should use profile path.   DEFAULT=
        -d,--device-id  <device-identifier> iOS Simulator GUID or 40-digit physical device ID
        -f,--force  <force-reinstall-app> [OPTIONAL]    Reinstall the app if the device contains an older version than the bundle specified DEFAULT=0
        -i,--resources-path <resources-path> [OPTIONAL]     Path to resources (executables) to inject into app directory. A list of colon separated files may be specified.
        -p,--profile-path   <profile-path> [OPTIONAL]   Path to provisioning profile
    install <app-path>
App com.apple.test.DeviceAgent-Runner is not installed on D58F24D7-FBE6-4D0F-B067-11CFADC4399F
Error installing application: Error Domain=com.facebook.FBSimulatorControl Code=0 "Simulator does not support any of the architectures ([x86_64, i386]) of the executable at /var/folders/f6/g6hvlkb96fd4v0cbf07lk45w0000gp/T/xdb/DeviceAgent.iOS.Dependencies/9a7eae887a041f733c06f5eef3e12600/app/DeviceAgent-Runner.app/DeviceAgent-Runner. Simulator Archs ([(null)])" UserInfo={NSLocalizedDescription=Simulator does not support any of the architectures ([x86_64, i386]) of the executable at /var/folders/f6/g6hvlkb96fd4v0cbf07lk45w0000gp/T/xdb/DeviceAgent.iOS.Dependencies/9a7eae887a041f733c06f5eef3e12600/app/DeviceAgent-Runner.app/DeviceAgent-Runner. Simulator Archs ([(null)])}

Best Answer

Answers

  • SteveDixSteveDix USMember ✭✭

    I'm getting exactly the same issue.

    Also running with Xamarin.UITest 2.2.4. Have tried iPhone 7, 8, X all with iOS 11.4.
    XCode 9.4.1
    Visual Studio for Mac (Enterprise) 7.5.2 (build 40)

  • sebastian.ferrarisebastian.ferrari USMember ✭✭

    Hi Guys, any news with this issue? I'm getting the same.

Sign In or Register to comment.