Forum Xamarin.Forms

Getting error pages doesn't exist and warning about .net framework when using Rg.Plugins.Popup

DevMaranDevMaran Member ✭✭
edited June 2018 in Xamarin.Forms

I want to show popup in my app and add the package Rg.Plugins.Popup on all platforms

and

Xaml Code:

then getting the issues

Description

1) Warning: Package 'Rg.Plugins.Popup 1.0.4' was restored using '.NETFramework,Version=v4.6.1' instead of the project target framework '.NETStandard,Version=v2.0'. This package may not be fully compatible with your project.

Steps to load the plugin with .NETStandard,Version=v2.0?

2) Error CS0234: The type or namespace name 'pages' does not exist in the namespace 'Xamarin.Forms' (are you missing an assembly reference?) (CS0234)

Steps to Reproduce

  1. Waring occurs when I add the NuGet package in my project for each platforms.
  2. Error occurs When I tried to build the app.
  3. Is this plugin support the below-mentioned configuration version

Xamarin.forms version 3.0.0.446417, Visual Studio (7.5.1) on mac,

.NET Core
Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
2.0.5
2.0.3
2.0.0
SDK: /usr/local/share/dotnet/sdk/2.1.4/Sdks
SDK Versions:
2.1.4
2.0.3
2.0.0
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.10.1/lib/mono/msbuild/15.0/bin/Sdks

Apple Developer Tools
Xcode 9.3 (14154)
Build 9E145

Xamarin.iOS
Version: 11.10.1.178 (Visual Studio Community)
Hash: 408d3574
Branch: d15-7
Build date: 2018-05-08 18:56:30-0400

Xamarin.Android
Version: 8.3.0.19 (Visual Studio Community)
Android SDK: /Users/devmaran/Documents/android-sdk-macosx
Supported Android versions:
4.4 (API level 19)
5.0 (API level 21)
5.1 (API level 22)
6.0 (API level 23)
7.0 (API level 24)
7.1 (API level 25)
8.0 (API level 26)
8.1 (API level 27)

SDK Tools Version: 26.1.1
SDK Platform Tools Version: 27.0.1
SDK Build Tools Version: 28 rc2

Java SDK: /usr
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

Best Answer

  • DevMaranDevMaran Member ✭✭
    Accepted Answer

    I have resolved the issue by using Pre-Released or can say a new version of "Rg.Plugins.Popup" NuGet package which is compatible with ".NETStandard,Version=v2.0".

Answers

  • DevMaranDevMaran Member ✭✭
    Accepted Answer

    I have resolved the issue by using Pre-Released or can say a new version of "Rg.Plugins.Popup" NuGet package which is compatible with ".NETStandard,Version=v2.0".

Sign In or Register to comment.