Updated sample FFImageLoading, SkiaSharp 1.60.1 could not install

stevehunterstevehunter Member ✭✭
edited May 2018 in General

I tried sample on vs for Mac:
https://github.com/HoussemDellai/FFImageLoading-XamarinForms-Demo

It compiled as is, but the packages were old. I tried updating everything (Xamarin forms and FFImageLoading). All worked including SkiaSharp in android and iOS, but the forms version didn't. Error is below.

Could not install package 'SkiaSharp 1.60.1'. You are trying to install this package into a project that targets '.NETPortable,Version=v4.5,Profile=Profile259', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

Ideas?

Posts

  • AshleyPringleAshleyPringle USMember ✭✭

    I am also having this problem. Skiasharp updates properly in iOS and Android projects, but not in the Forms project.

    The console says:

    Package SkiaSharp 1.60.1 is not compatible with portable45-net45+win8+wpa81 (.NETPortable,Version=v4.5,Profile=Profile111). Package SkiaSharp 1.60.1 supports:
    - monoandroid (MonoAndroid,Version=v0.0)
    - net45 (.NETFramework,Version=v4.5)
    - netstandard1.3 (.NETStandard,Version=v1.3)
    - tizen40 (Tizen,Version=v4.0)
    - uap10.0 (UAP,Version=v10.0)
    - xamarinios (Xamarin.iOS,Version=v0.0)
    - xamarinmac20 (Xamarin.Mac,Version=v2.0)
    - xamarintvos (Xamarin.TVOS,Version=v0.0)
    - xamarinwatchos (Xamarin.WatchOS,Version=v0.0)

    Package SkiaSharp.Views.Forms 1.60.1 is not compatible with portable45-net45+win8+wpa81 (.NETPortable,Version=v4.5,Profile=Profile111). Package SkiaSharp.Views.Forms 1.60.1 supports:
    - monoandroid (MonoAndroid,Version=v0.0)
    - netstandard1.3 (.NETStandard,Version=v1.3)
    - tizen40 (Tizen,Version=v4.0)
    - uap10.0 (UAP,Version=v10.0)
    - xamarinios (Xamarin.iOS,Version=v0.0)
    - xamarinmac20 (Xamarin.Mac,Version=v2.0)

Sign In or Register to comment.