Forum Xamarin.Android

Can't Archive App - Shared Mono runtime is enabled for ''

StephenElyStephenEly USMember ✭✭

I am currently unable to archive my Android app. Xamarin reports the following:

Shared Mono runtime is enabled for ''.
The selected build configuration is using the shared Mono runtime for faster deployment. Apps cannot be archived with this setting enabled.
Please ensure that you are using a release configuration and that the "Use Shared Mono Runtime" option in your project's build options is unchecked.

I've confirmed I'm in Release configuration as always, and the shared runtime option on my project is not selected. Is this a new issue in a recent release? Did something get messed up in my project? It's suspicious to me that the error doesn't list my actual Android project, just an empty string. Help me, please!

Posts

  • StephenElyStephenEly USMember ✭✭

    I have no idea why, but this seems to have resolved itself. I'd cleaned the solution multiple times prior, but I went back to the code-base for my last good build, worked my way forward, and when I got to the latest code it worked no problem. Bizarre.

  • davindaviesdavindavies Member

    ran it to the same issue sorted it out by turning it off on all configurations

  • How do you turn off Shared Mono for all configurations?

  • axaaxa Member ✭✭✭
    edited March 2019

    hey Xamarin, why cant this be enabled for archiving and release? my devices report a reduced sized app by 66% with it enabled.

  • Try changing solution configuration from 'Debug' to 'Release' mode, it's at the toolbar at the top of Visual Studio. That worked for me.

  • VendulkaVendulka Member

    No solution worked for me. I set false for all configurations, I built the solution many times and I still can't archive for the same reasons. I really don't know what to do with it anymore! :(

Sign In or Register to comment.