Unable to add apple developer account or failed automatic provisioning

sumitmishrasumitmishra Member ✭✭✭

Hi,
We have suddenly got an issue when we add apple developer account in visual studio for mac or set automatic provisioning.
Its showing "Failed to synchronize [email protected] account with Apple Developer Portal".

Unexpected authentication failure. Reason: {
"authType" : "sa"
}

Please guide to solve this issue.

Best Answer

Answers

  • fl034fl034 DEMember ✭✭

    Same here, is there a way to make a Release Build and sign/provision it completely via Xcode?
    I need a quick solution :#

  • fl034fl034 DEMember ✭✭

    I updated fastlane via rubygems to 2.96.0 but the problem persists. Despite this should be fixed in this version (see fastlane releases on github)

    Is there a possibility that I have multiple fastlane installations on my mac?

  • akauakau USMember

    Same here in Visual Studio with main Apple account and when I try to add a new Apple account... I really need a solution in order to deploy my app please

  • RobertoBrionesRobertoBriones Member ✭✭

    Same here

  • GuyLemireGuyLemire USMember ✭✭

    I am having the same issue, unfortunately the subscription expired (never got a reminder email) and since then our ad-hoc app gives the error "App" is No Longer Available I tried to redeploy and see if that would fix it but I cannot add the auto provision and I get the error Could not find any available provisioning profile for iOS

  • criistiicriistii USMember ✭✭

    Same problem here, even on multiple iMacs.

  • YasserMoradiYasserMoradi USMember

    Me too )-:

  • fl034fl034 DEMember ✭✭

    I managed to make an release build by setting the Scheme to manual provisioning inside Info.plist.
    Then click iOS bundle Signing and set Signing Identity to Distribution (automatic) and Provisioning Profile to Automatic for configuration "Release" on Platform iPhone.

    After that select Release mode in the upper left corner.
    Then you can click Build > Archive for publishing.

    Take the new created Archive and drag it onto Xcode to export the app from there.

  • CodeSenseiCodeSensei USMember ✭✭

    Having the same issue, any ideas?

  • CarlosMendezCarlosMendez USMember

    Hi guys, the problem is on Xcode, you have to update it!!!

  • sumitmishrasumitmishra Member ✭✭✭

    Thanks a lot @Oleg_Demchenko. It's worked..

  • akauakau USMember

    It works ! Thanks @Oleg_Demchenko !

  • dinobdinob USUniversity ✭✭✭

    My reason is "hsa2" as per image below but following your instructions, I was able to resolve.

    Thank you

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    Un..be..leavable...
    I had to sign in to both links, @Oleg_Demchenko has provided and accept the new privacy statements from apple to be able to add my apple account in VS2017 (without any meaningful error message)!
    It still not works, but I now have other error messages, what means, that I have done an step forward...
    So thanks @Oleg_Demchenko :sunglasses:

  • Oleg_DemchenkoOleg_Demchenko RUMember ✭✭
    edited July 2018

    Hi @FredyWenger,

    Could you provide more information about these other error messages?

    Thanks

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    Hi @Oleg_Demchenko

    I had a .forms (2.3.0.49) project under VS2015 update 3 and am on the way to .forms 3.1.x and VS2017.
    I only have used the Android project in this project yet and now want to bring also the iOS project (and the MAC connection) to work unter VS2017...
    Therefore, I have to update the whole environment (including MAC with Xamarin Studio and Xcode).
    The error messages I mentioned are related to the Xcode installation on the MAC (that I have to update right now).
    I was stuck by the connection to the MAC and signing the package (Apple) where your posting has helped me to come a step forward (thanks again for this posting).

    If you are interested, you can read the whole story (later) under this thread:
    https://forums.xamarin.com/discussion/127102/the-vs2017-and-forms-update-thread#latest

    I will post my findings (especially for other users, that have to migrate to .forms 3.1.x and VS2017 like me) there, as soon as I have finished my migration.
    Greetings from Switzerland

  • Hi, @FredyWenger did you manage to resolve this. I've tried updating and reinstalling newest versions of both XCode and VS, so both are fully up to date, also accepted new terms with apple on al sites mentioned here. I can add my apple account, but still can't set up Automatic Provisioning? Any more ideas?

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @AdrenalDaisy
    As I wrote, at this point, I had error messages regarding the Xcode version on the MAC.
    I then had incredible problems to update Xcode on the MAC (update has not worked -> I ended up in a complete new installation of Xcode).
    If you have problems to set "Automatic Provisioning", I think, something is wrong with your environment (what also can be a small "logical" problem).
    I would open all related tools (XCode, Xamarin Studio on the MAC, access the Apple portals) and check, if you can see open issues. As I - e.g. - don't have used Xamarin Studio on the MAC for a longer time, the version was "downgraded" to a "community version". I had to enter my MS-Account to become a professional version again (it seems as it has checked my Visual Studio account and seen, that I have a VS prof. Abo).
    Maybe, you also may have a problem with your Apple dev-keys...

  • crawfordnetcrawfordnet Member ✭✭

    worked on my iMac, but not on my MacBook Pro.

    Between the whole .net core versioning crap and this, I'm about to toss Visual Studio Mac out the window and start using Xcode. This is such a productivity loser I don't know where to begin.

Sign In or Register to comment.