Forum General

Xamarin Studio Bug when consume web service

In the reference.cs the system tell me the tyme 'schema' in the auto generated code is not recognized!

///
[System.CodeDom.Compiler.GeneratedCodeAttribute("XamarinStudio", "4.0.0.0")]
[System.SerializableAttribute()]
[System.Diagnostics.DebuggerStepThroughAttribute()]
[System.ComponentModel.DesignerCategoryAttribute("code")]
[System.Xml.Serialization.XmlTypeAttribute(AnonymousType=true, Namespace="http://tempuri.org/")]
public partial class getClientDataResponseGetClientDataResult {

private schema schemaField;

private System.Xml.XmlElement anyField;

/// <remarks/>
[System.Xml.Serialization.XmlElementAttribute(Namespace="http://www.w3.org/2001/XMLSchema", Order=0)]
public schema schema {
    get {
        return this.schemaField;
    }
    set {
        this.schemaField = value;
    }
}

/// <remarks/>
[System.Xml.Serialization.XmlAnyElementAttribute(Order=1)]
public System.Xml.XmlElement Any {
    get {
        return this.anyField;
    }
    set {
        this.anyField = value;
    }
}

}

Posts

  • Yes but none one respond anything to it and I need to show at my manager that this application may help us so he can create the expence report to buy it!

  • EidandEidand GBMember, University ✭✭✭

    why don't you simply create a rest service, then you don't need to add any references.

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    From the other posts, it appears that mhutch asked for a bug report to be filed (which you have done), so I don't know what else you want us to do.

  • Well, that statement is really poor, the error is generated on an auto generated code of your application, you should be able to provide at least a work around; is this the kind on support that we will expect if my company buy your software?, just fill a form and wait! do you understand that people will be waiting for a response in order to continue working, I understand that this is just a trial and if we buy it you may change the level of interest to resolve this, but how can we even considerate you as an option if we can't even run a simple application with out errors, and you interest to resolve it is this poorly!

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    Do you understand that I don't work for Xamarin? These are the community forums, not the official support channels.

    If you aren't getting any immediate assistance here, then it means the community doesn't know how to solve or workaround your problem. Since you got a response from the developers asking you to open a bug report, it means that they need to look into your problem more deeply and, therefore, they don't have an immediate solution or workaround to your problem either.

    Since many Xamarin users are consuming web services with Xamarin successfully, it appears that your particular situation is unique or unusual. It may take time for them to figure out what the problem is.

  • Oh, sorry, by the way that you refer earlier I got the impression that you work for Xamarin, I was already mad with the customer service provided!

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    No worries. I understand your frustration.

  • EidandEidand GBMember, University ✭✭✭

    Some valid points are raised here and I am in the exact same situation. I cannot recommend my company uses Xamarin, if I can't even get a simple app to work / build.

    This is precisely why xamarin need to up their game if they want to be taken seriously in this space.

Sign In or Register to comment.