Forum Visual Studio

Cannot resolve symbol InitializeComponent

BozhiQianBozhiQian AUUniversity ✭✭

Hi all,
I just updated VS2017 to the latest version 15.7 which include Xamarin.Form 3.0. Now I created Blank xamarin form app with net standard to be selected. Open 'MainPage.xaml.cs', InitializeComponent line is in red that indicate "Cannot resolve symbol InitializeComponent". I can build the whole solution successfully.

If I add any UI element in the 'MainPage.xaml', these elements referenced in the code behind file displayed in red. I still can build but just feel not confitable seeing these red error.

Tagged:

Answers

  • toumirtoumir USMember ✭✭

    before updating my project works fine but after update to 15.7 and XF 3 I get this error in all my page constructors, "Cannot resolve symbol InitializeComponent". try to delete obj and bin folder the pb remains! can anyone help ?

  • BozhiQianBozhiQian AUUniversity ✭✭

    @toumir That's the same issue happened to me. Do you use Resharper? I am not sure if this issue is to do with Resharper or not.

  • toumirtoumir USMember ✭✭

    yes I use Resharper

  • BozhiQianBozhiQian AUUniversity ✭✭

    @toumir
    I go to "Tools -> Extensions and Updates..." from VS2017 menu, and disable "JetBrains Resharper ..." and then restart VS2017, this issue is disapeared. I believe we may have to wait fix from Resharper in next release after the end of June. For now, I still have to use Resharper so just ignore this issue as it still be built.

  • BozhiQianBozhiQian AUUniversity ✭✭

    I just found someone has reported this issue at https://youtrack.jetbrains.com/issue/RSRP-469562

Sign In or Register to comment.