Error Package System.Device.Location.Portable is not compatible with monoandroid81

I am working on Xamarin Forms app with VS2015 with Xamarin 4.5.1.481, Xamarin.Andorid 7.3.1.2 and Xamarin.iOS 10.10.0.36 wherein we use System.Device.Location.Portable 1.0.0 NuGet package. Everything works fine.

Now, I am using VS2017 and have updated my visual studio to 15.7.0 which has automatically updated the following:

  • Xamarin 4.10.0.440
  • Xamarin.Android SDK 8.3.0.18
  • Xamarin.iOS and Xamarin.Mac SDK 11.10.1.174

I get the following build errors when i install 'System.Device.Location.Portable 1.0.0'
1. Error NU1202 Package System.Device.Location.Portable 1.0.0 is not compatible with xamarinios10 (Xamarin.iOS,Version=v1.0) / win-x86. Package System.Device.Location.Portable 1.0.0 supports: net (.NETFramework,Version=v0.0)
2. Error NU1202 Package System.Device.Location.Portable 1.0.0 is not compatible with monoandroid81 (MonoAndroid,Version=v8.1). Package System.Device.Location.Portable 1.0.0 supports: net (.NETFramework,Version=v0.0)

The System.Device.Location. The portable package does not have any other version so that I can make it compatible.

Any help will be grateful. Thanks in advance.

Sign In or Register to comment.