Forum Xamarin.Forms
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Serious deployment problem: Data gets reset

MLyrstadMLyrstad Member ✭✭

I have no clue what's going on here. This is really weird.

Every time I run our app from Visual Studio, application properties gets reset to an older version. They're not the default values, nor are they the values I've tried to set. If I close the app on the device to the point that Visual Studio disconnects, then restart the app on the device, the settings are fine. When I start the app from Visual Studio again (haven't even made code changes) the settings have been reset again. The values are not being explicitly set to these values in our configuration class, it's the data source that's changed (it seems like). I've tried both settings of the deployment cache setting to no avail. I'm running out of time and I can't properly debug our app because of this as I need to reconfigure every time.

I'm not exactly optimistic, but... does anyone have any kind of clue?


  • MLyrstadMLyrstad Member ✭✭

    Further information:

    This seems to work right on the emulator, but not on my physical device.

    Well. At least I can move on with my development with the emulator, but I hope someone can figure this one out. My device is a Sony G8141.

Sign In or Register to comment.