No Xamarin UI test is available

XcodXamXcodXam RUMember ✭✭

I just try to start my Xamarin ui test but get an error :

No test is available in F:...UI.Tests.dll.
Make sure that test discoverer & executors are registered and platform & framework version settings are appropriate and try again.

Whats the problem there? Yesterday all was fine.

Tagged:

Posts

  • JesseLibertyJesseLiberty USInsider, University ✭✭✭

    Did you solve this?

  • HosepHosep Member
    edited May 16

    Hey there!
    I had the same issue and I fixed it with the following approach:

    Preconditions: I run Visual Studio Professional 2017 v15.6.7

    1. Go to Tools -> Extensions and Updates
    2. Then search for NUnit Test Adapter (Currently I use NUnit 2 Test Adapter but it depends on which version of the NuGet Package of NUnit Test Adapter is used in your solution - if you run the NUnit 3 Test Adapter - search for that one instead)
    3. Check if it's installed there, if not - simply install it. It requires a restart of your Visual Studio and that's it.

    That solved the problem for me.

Sign In or Register to comment.