Forum General
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Updating Xamarin support plugins correctly.

Balck_PantherBalck_Panther LKMember ✭✭

I have to try to update support libraries but always it getting errors as follow. I have done everything but no luck. (Uninstall all libraries and install one by one) Is there any way to do it

NU1608: Detected package version outside of dependency constraint: Xamarin.Android.Support.Design 25.4.0.2 requires Xamarin.Android.Support.v7.AppCompat (= 25.4.0.2) but version Xamarin.Android.Support.v7.AppCompat 27.0.2 was resolved.
NU1608: Detected package version outside of dependency constraint: Xamarin.Android.Support.v7.MediaRouter 25.4.0.2 requires Xamarin.Android.Support.v7.AppCompat (= 25.4.0.2) but version Xamarin.Android.Support.v7.AppCompat 27.0.2 was resolved.
NU1107: Version conflict detected for Xamarin.Android.Support.Compat. Reference the package directly from the project to resolve this issue.
App10.Android -> Xamarin.Android.Support.v7.AppCompat 27.0.2 -> Xamarin.Android.Support.Compat (= 27.0.2)
App10.Android -> Xamarin.Android.Support.Design 25.4.0.2 -> Xamarin.Android.Support.Compat (= 25.4.0.2).
Package restore failed. Rolling back package changes for 'App10.Android'.

Posts

  • MarcoTronconeMarcoTroncone GBUniversity ✭✭✭
    edited April 2018

    close you solution and open your csproj file.

    Update it changing manually the version of ALL support packages from 25.4.0.2 to 27.0.2.

    When you open your solution again it will update automatically and correctly the support packages.

Sign In or Register to comment.