Exception while loading assemblies: netstandar issue!

juanzeta33juanzeta33 USMember ✭✭

Hi everyone,

I am working on a project and a couple of days ago, I have not been able to execute the application since it sent me the following error:

Error Exception while loading assemblies: System.IO.FileNotFoundException: Could not load assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51'. Perhaps it doesn't exist in the Mono for Android profile?
File name: 'netstandard.dll'
at Java.Interop.Tools.Cecil.DirectoryAssemblyResolver.Resolve(AssemblyNameReference reference, ReaderParameters parameters)
at Xamarin.Android.Tasks.ResolveAssemblies.AddAssemblyReferences(DirectoryAssemblyResolver resolver, ICollection`1 assemblies, AssemblyDefinition assembly, Boolean topLevel)
at Xamarin.Android.Tasks.ResolveAssemblies.Execute(DirectoryAssemblyResolver resolver) AnconApp.Android C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets 1413

I tried:
1. Update Visual Studio 2017 to the lastest version (15.6)
2. Update NugetPackage Components
3. Delete and reload NugetPackage Components
4. Install VS 2015 and build the app
5. Clear, build and rebuild the solution.

But nothing can delete the error.

Anybody have the same issue and solved?

Any Help?

Sign In or Register to comment.