I'm not able to start native "Contacts" android app on android 6.0 emulator

Hi everyone,

I wrote a simple test using Xamarin.UITest.

I'm trying to start native "Contacts" android app on android 6.0 emulator using the following line:

ConfigureApp.Android.InstalledApp("com.android.contacts").StartApp(AppDataMode.Clear);

Once I run the test, I get the following error in my Visual Studio 2017:

Test Name: CanEnterCodeAndClickOnGenerateButton
Test FullName: XamarinStore.Tests.SmokeTest.CanEnterCodeAndClickOnGenerateButton
Test Source: C:\Users\ahmetmu\Source\Repos\Xamarin.UITest\XamarinStore.Tests\TestClass.cs : line 39
Test Outcome: Failed
Test Duration: 0:01:02.926

Result StackTrace:
at Xamarin.UITest.Shared.Android.Commands.CommandAdbClearAppData.ExecuteLocally(Func'2 adbShell)
at Xamarin.UITest.Shared.Android.Commands.CommandAdbClearAppData.Execute(AdbProcessRunner processRunner)
at Xamarin.UITest.Shared.Execution.Executor.Execute[TDep1](ICommand'1 command)
at Xamarin.UITest.Shared.Android.LocalAndroidAppLifeCycle.EnsureInstalled(String appPackageName, ApkFile testServerApkFile)
at Xamarin.UITest.Android.AndroidApp..ctor(IAndroidAppConfiguration appConfiguration, IExecutor executor)
at Xamarin.UITest.Configuration.AndroidAppConfigurator.StartApp(AppDataMode appDataMode)
at XamarinStore.Tests.SmokeTest.Setup() in C:\Users\ahmetmu\Source\Repos\Xamarin.UITest\XamarinStore.Tests\TestClass.cs:line 30
Result Message: System.Exception : Timed out waiting for result of ClearAppData2
Result StandardOutput:
WARNING: Tests created using NUnit 3.10.1.0 cannot be uploaded to Test Cloud. The recommended version is 2.6.4.
Full log file: C:\Users\ahmetmu\AppData\Local\Temp\uitest\log-2018-03-13_18-27-17-145.txt
Skipping IDE integration as important properties are configured. To force IDE integration, add .PreferIdeSettings() to ConfigureApp.
Android test running Xamarin.UITest version: 2.2.3
Initializing Android app on device emulator-5554 with installed app: com.android.contacts
Skipping local screenshots. Can be enabled with EnableScreenshots() when configuring app.
Signing apk with internal keystore.
Skipping installation: Already installed.

Can someone please help me fix this problem?

Thank you in advance.

Sign In or Register to comment.