NuGet Package restore failed - Facebook.Android SDK

Hey,

I'm trying to install the Xamarin.Facebook.Android NuGet-Package but I always get this error message:

Restoring packages for C:\Users\Kernobee\source\repos\App1\App1\App1.Android\App1.Android.csproj... Version conflict detected for Xamarin.Android.Support.Compat. Reference the package directly from the project to resolve this issue. App1.Android -> Xamarin.Android.Support.v7.MediaRouter 26.1.0.1 -> Xamarin.Android.Support.v7.Palette 26.1.0.1 -> Xamarin.Android.Support.Compat (= 26.1.0.1) App1.Android -> Xamarin.Facebook.Android 4.26.0 -> Xamarin.Android.Support.CustomTabs 25.3.1 -> Xamarin.Android.Support.Compat (= 25.3.1). Package restore failed. Rolling back package changes for 'App1.Android'.

(I'm running: Visual Studio Community 2017 Version 15.5.6)

Does someone know how I can fix this Problem?
Would really appreciate some help :)

Answers

  • KernobeeKernobee Member

    Ok, I just fixed it myself.. Sorry for asking but It really took me a long time :sweat_smile:

    I had to install the "Xamarin.Android.Support.Compat" package from the NuGet Manager.

Sign In or Register to comment.