Forum Visual Studio

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Live Player is getting wrong device IP address

JonAlzaJonAlza ESMember ✭✭✭
edited February 2018 in Visual Studio

Hello:

I updated my Visual Studio Enterprise 2017 to Version 15.5.6. When I opened a Xamarin project I noticed a message that suggested me to test Xamarin Live Player. I tried it but I have some problems. Here is the first:

In my office, due to different reasons, we use 2.4GHz and 5Ghz frequencies to connect to the same Wi-Fi network. We use Class B network (172.16.X.Y) Normally, I connect my laptop with 5GHz frequency and my Android device can only connect with 2.4GHz frequency. When I pair the phone Xamarin Live Player gets a wrong Class C networt IP address (10.A.B.C).

This is what I get on Output window when I run the app:

Start ({MyPhoneApp}.Android, {My Android device} Player, ).
Attempting connection to debug address: {Crazy Class C IP address}:37847.
Unable to deploy to {My Android device} Player, please ensure the Xamarin Live Player app is open and the device is on the same network as Visual Studio.
Failed to debug your app.

I tried to configure PlayerDeviceList.xml file, but in the second attempt Visual Studio overwrites the file again with the wrong IP address.

If I connect my laptop with 2.4GHz frequency, Visual Studio gets the right IP address.

Tagged:
Sign In or Register to comment.