Unable to debug on device using Visual Studio 2013

I am unable to debug on a device, using visual studio 2013. It only works on the simulator.

The log shows something like this:

</p> <pre> Starting debug on:iPhone Remote build finished... Debugging session ended. Debugging session ended. </pre> <p>

But nothing happens.

I have:

1) generated a certificate and provisioning profile using the developer center
2) installed the certificate on the mac (into keychain)
3) installed the provisioning profile onto the iphone
4) opened the project properties in visual studio and went to "ios bundle sigining", but:
the only options for identity are "developer (automatic)" and "distribution (automatic)"
the only option for provisioning profile is "Automatic"

What do I need to do?

Posts

  • MarkusDoppMarkusDopp DEMember

    Hi I´ve got the same problem.. Simulator runs flawlessly but I can not start debug or release on the device..

    Mac log:
    Is empty

    Debug log:
    Remote build finished...
    Debugging session ended.
    Debugging session ended.
    The program '[6308] MobileiOS.vshost.exe' has exited with code 0 (0x0).

  • I have the same problem. the application runs in the xamarin studio MAC but in the VS recognize the device but not work

  • ErikFAndersenErikFAndersen DKMember ✭✭

    You need to enter your Apple ID in Xamarin Studio on the Mac

  • AbePleasantAbePleasant USMember ✭✭

    Is that mandatory? I mean will Visual Studio always use Xamarin Studio on the mac machine?

    And if I don't have access to the Apple account itself (only to the certificates and provisioning profiles provided to me) then how can I make this work? This is possible in other platforms such as phonegap build.

  • ErikFAndersenErikFAndersen DKMember ✭✭

    I don't know. I only know that this worked for me.

    I'm pretty sure that Xamarin Studio is used to compile your project regardless.

  • R-EastmanR-Eastman USMember

    I'm pretty much getting the same thing, except:

    • iOS projects run in my Xamarin on mac and my Apple ID is in the Xamarin studio on mac

    • my mac log has a few lines in it:
      [29-Jan-2014 18:52:18] Handling with command: [Info: CommmandUrl=Info] (11)
      [29-Jan-2014 18:52:18] Attempting to acquire command execution lock, timeout set to 00:10:00
      [29-Jan-2014 18:52:18] mtouch 7.0.5.2 (9c42159)

    that's it on the log. Other then that same deal, running on Windows and VS2013.

    Any ideas?

    Thanks!
    [29-Jan-2014 18:52:18] Command [Info: CommmandUrl=Info] finished (11)

  • R-EastmanR-Eastman USMember

    I'd like to also add that in VS2013 I have the Green Check for connection status and am paired with the mac, however refresh build server info comes up with a warning that "Failed to obtain information about the remote's profile files. Unable to check SDK status."

    Also "Show iOS simulator" produces an error "Failed to change active application on server"

    So it seems that I'm paired but the build host isn't responding other then the few log lines above in my previous message.

  • R-EastmanR-Eastman USMember

    Ok my problem is solved, for me it was that the clocks between the windows machine and the mac were off a few minutes. Syncing them solved my problem entirely.

Sign In or Register to comment.