Forum Cross Platform with Xamarin

PCL - SocketIOClientDotNet install problem

I have a Xamarin application where I attempting to add the SocketIOClientDotNet nuget package. Will this package work in the PCL? The following is the error I receive when attempting to install it in my Visual Studio for MAC v7.3.3. I have also tried different profiles and I haven't found one that works.

Checking compatibility for SocketIoClientDotNet 1.0.4 with .NETPortable,Version=v4.6,Profile=Profile44.
Package SocketIoClientDotNet 1.0.4 is not compatible with portable46-net451+win81 (.NETPortable,Version=v4.6,Profile=Profile44). Package SocketIoClientDotNet 1.0.4 supports:
- net35 (.NETFramework,Version=v3.5)
- net40 (.NETFramework,Version=v4.0)
- net45 (.NETFramework,Version=v4.5)
- netstandard1.3 (.NETStandard,Version=v1.3)

Thanks in advance,
Allan

Tagged:

Best Answer

Answers

Sign In or Register to comment.