Followed sandbox directions, but app still doesn't run as sandboxed

MichaelBothMichaelBoth ✭✭✭AUMember ✭✭✭

We're looking to get our mature Xamarin Mac application published on the app store, so I've started down the path of finding out what needs to be changed to enable this to happen, and the first step is to attempt to get the app running in 'sandboxed' mode. I've followed this procedure here to the letter:
https://developer.xamarin.com/guides/mac/application_fundamentals/sandboxing/
... but the app still is NOT running as 'sandboxed' (according to Activity Monitor), and it's operation definitely seems normal (i.e. it isn't causing exceptions or problems that I would expect it to cause due to the way we use some local files etc).

One question I have is that in the "Enable the app sandbox" step it instructs "Check both Enable Entitlements and Enable App Sandboxing", however I can't see any "Enable Entitlements" checkbox or option. Is that what I'm missing?

OS and app info:
macOS 10.13.3
VS Community 7.3.3 (build 5)
Xamarin Mac 4.0.0.215
Xcode 9.2 (13772)

Any suggestions as how to work out what the problem is?

Thanks

Mike

Tagged:

Best Answers

  • ChrisHamonsChrisHamons Xamurai US Xamurai
    Accepted Answer

    Hmm, the documentation might be stale. A few things to check (we'll update the docs depending on what we find missing):

    • Entitlements.plist - Enable App Sandbox
    • Project Options, Mac Signing:
      • Sign the bundle checkbox.
      • Set an ID.
      • Set Custom Entitlements as your Entitlements.plist

    With those set, I have a sandboxed app.

  • DavidLilleyDavidLilley ✭✭✭ US ✭✭✭
    Accepted Answer

    Look at step 6 of https://developer.xamarin.com/guides/mac/application_fundamentals/sandboxing/

    I suspect that might help

    "Select Mac Signing, then check Sign the application bundle and Sign the installer package. Under Provisioning profile, select the one we created above:"

Answers

  • ChrisHamonsChrisHamons Xamurai USForum Administrator, Xamarin Team Xamurai
    Accepted Answer

    Hmm, the documentation might be stale. A few things to check (we'll update the docs depending on what we find missing):

    • Entitlements.plist - Enable App Sandbox
    • Project Options, Mac Signing:
      • Sign the bundle checkbox.
      • Set an ID.
      • Set Custom Entitlements as your Entitlements.plist

    With those set, I have a sandboxed app.

  • DavidLilleyDavidLilley ✭✭✭ USMember ✭✭✭
    Accepted Answer

    Look at step 6 of https://developer.xamarin.com/guides/mac/application_fundamentals/sandboxing/

    I suspect that might help

    "Select Mac Signing, then check Sign the application bundle and Sign the installer package. Under Provisioning profile, select the one we created above:"

  • MichaelBothMichaelBoth ✭✭✭ AUMember ✭✭✭

    Thanks Chris and David - I had indeed overlooked the "Set Custom Entitlements" setting - gah! - and once I'd configured that my App is now running in sandbox mode. It certainly helped Chris explicitly mentioning this, I might add.

    Many thanks for the assistance.

Sign In or Register to comment.