Forum Xamarin.Forms

Does anyone use SignalR in Xamarin .net Standard 1.4 with Autofac

LinnKristinLinnKristin NOUniversity ✭✭

Does anyone use SignalR in Xamarin .net Standard 1.4 with Autofac ?

I try to follow https://github.com/IncredibleWeb/Xamarin-Forms-Chat-Client , but then I saw that there is some issues with autofac, so I found http://autofaccn.readthedocs.io/…/…/integration/signalr.html , but this pacage does not support .net Standard 1.4.
Error: Package Autofac.SignalR 3.0.2 is not compatible with netstandard1.4 (.NETStandard,Version=v1.4). Package Autofac.SignalR 3.0.2 supports: net40 (.NETFramework,Version=v4.0)

I tried to new up a new instans of my signalR class without using Autofac, but then i get "System.ExecutionEngineException: Attempting to JIT compile method"

I also tried to add the the Autofac.SignalR directly in my . net forms project, but then I need Owin, that gives me Package Owin 1.0.0 is not compatible with netstandard1.4 (.NETStandard,Version=v1.4). Package Owin 1.0.0 supports: net40 (.NETFramework,Version=v4.0)

Is there anyway to get around this ?

Sign In or Register to comment.