Forum Xamarin.Android
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

New Android tablet, but unable to deploy

JohnHJohnH GBMember ✭✭✭✭✭

Hi guys,
Just purchased a noname droid tablet (very cheap off Amazon) to help me convert my app to Zamarin.Droid. Unfortunately it isn't coming up in the list of devices when I compile and run.
Ive done the usual, enabled USB Debugging, Allow installation from unknown sources, but the device just wont show. I can copy a release build apk to the device and install it manually and it runs, but obviously I'll need to run and debug. I do however have a droid mobile which does work, but need to get the tablet working as well. About tablet reports its running 4.1.1, my min version of my app is 4.0.

Any suggestions on what I should do? Im developing on a mac.

Cheers
John

Posts

  • TomOpgenorthTomOpgenorth CAXamarin Team Xamurai

    A couple of things to try:

    • Try a different USB cable (I have one that just won't work with my Nexus 1).
    • manually restart ADB through Terminal.
    • Reboot the device.
  • JohnHJohnH GBMember ✭✭✭✭✭

    Thank you Tony, you helped point me in the right direction.
    I had tried a different cable and rebooted, no luck. What I needed to do was add the vendor id to the adb_ubs.ini file, as outlined in the following post:
    stackoverflow.com/questions/7135999/adb-not-finding-my-device-phone-macos-x

    Also I don't know why but I couldn't restart adb via the terminal, so I simply rebooted.

Sign In or Register to comment.