Unable to connect to xamarin live player

Hi

Unable to connect my android phone to visual studio through xamarin player.

Connection test : Wifi : turnedon, ip : valid, Server access : Not reachable - Unable to aaccess remote server. Please ensure port 8090 is open to outbound traffic. Do i need to run any server on machine?

Mobile : wifi , Desktop : LAN but both sharing the same network in same IP series.

Please anyone help me out from this issue.

Thanks in advance

Answers

  • TobieHeynsTobieHeyns USMember
    Have the same issue. Tried several different internet connections. Did it get resolved?
  • basitzia.6430basitzia.6430 USMember ✭✭

    Facing the exact same issue. Even tried to add the port in firewall but still not working.

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Thanks for the report. Looks like the handshake server communication was down for a short time. It should be up and running now.

  • @JamesMontemagno I had tried it many times but unable to connect it. It says unable to connect to remote server. I am afraid whether the local server to connect to xamarin player is running or not in Visual Studio. (Please ensure port 8090 is open to outbound traffic).

  • BarryBatsbakBarryBatsbak Member

    I have this issue since a few days, nothing was wrong before that. I've tried reinstalling, using static IP addresses but nothing won't make it connect to my VS instance. Any update on this problem?

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    If for some reason you can not communicate with the pairing server you can try to manually configure the device: https://forums.xamarin.com/discussion/116771/manually-configuring-a-device/

  • NomanSadiqNomanSadiq USMember

    I resolved by pressing following key combinations shift + Alt + F5 and its works

  • hippo604hippo604 Member
    edited October 1

    I am writing to confirm that NomanSadiq's key press does something for me.

    Today I installed Gorilla Player and my Live Player seems to have stopped working, but I recall I had this same problem for another reason some time ago.
    Running VS 15.8.5

    Sequence of events:
    1. I click Live Pl1. ayer. Xamrin LIve Player displays the QR code.
    2. I click "Pair again", and point my phone towards the QR code. For a second, it looks like the QR code is accepted and everything is ok. But my phone says "Lost connection to Visual Studio". In the Output window I get the message "Could not connect to the debugger."
    3. BUT then I use NomanSadiq's key press (Shift Alt F5) and I get the following in the output window:

    Getting project information...
    Start Lists3_20180930.Android, Motorola Moto G (5) Plus Player, Lists3_20180930.Lists.
    Attempting connection to debug address: 0.0.0.0:37847.
    'AddressNotAvailable' socket error while trying to connect directly to the device.
    Connected to: 192.168.1.67:42737.
    Deploying C:\Source\Repos_201802_Xam\Lists3_20180930\Lists3_20180930\Lists3_20180930.Android\Lists3_20180930.Android.csproj...
    Got device info: Motorola Moto G (5) Plus Player (Android) @ 0.0.0.0:37847
    Synchronizing files...
    Building and running...
    Built with 0 messages.
    Deploy to Motorola Moto G (5) Plus Player succeeded.

    And the compiled page displays on my Android. Does anyone know why this worked?!

Sign In or Register to comment.