REPL Tool does not work on higher Xamarin UITest versions for Windows

viasidoviasido Member

I decided to continue working on a project that was working on a Mac machine to a Windows machine. When I wanted to use the REPL tool, an error message appears.

Android SDK Path: C:\Android"
Full log file: C:\Users\msido\AppData\Local\Temp\uitest\log-2017-12-21_20-07-45-254.txt
Error creating directory info from path: "C:\Android""
Exception: System.ArgumentException: Illegal characters in path.
at System.IO.Path.LegacyNormalizePath(String path, Boolean fullCheck, Int32 maxPathLength, Boolean expandShortPaths)
at System.IO.Path.GetFullPathInternal(String path)
at System.IO.DirectoryInfo.Init(String path, Boolean checkHost)
at Xamarin.UITest.Shared.Dependencies.PotentialLocation..ctor(String path, String source)
Execution failed with exception: System.NullReferenceException: Object reference not set to an instance of an object.
at Xamarin.UITest.Shared.Dependencies.AndroidSdkFinder.GetTools()
at Xamarin.UITest.Shared.Android.DefaultAndroidFactory.BuildExecutor(IProcessRunner processRunner)
at Xamarin.UITest.Android.AndroidApp..ctor(IAndroidAppConfiguration appConfiguration, IExecutor executor)
at .Host(Object& $retval)
at Mono.CSharp.Evaluator.Evaluate(String input, Object& result, Boolean& result_set)
at Xamarin.UITest.Repl.Evaluation.MonoCSharpReplEngine.Evaluate(String line)
at Xamarin.UITest.Repl.Program.Main(String[] args)
Press any key to exit.

I tried comparing other projects in my Windows machine that was working, and I saw that it uses a lower version of Xamarin UITest and so I tried updating the project's version of Xamarin to 1.3.8, and it worked!

Tagged:
Sign In or Register to comment.