Help setting up dev environment

DaveAlessiDaveAlessi USMember ✭✭

New to xamarin. Trying to follow xamarin university tutorials. Experienced C#/Visual studio developer.

I am running the VS2017 community edition. I have run the installer and added xamarin forms. When I create a new solution, the project types do not match the tutorials (Tutorials are for VS 2015). After creating a solution, when I try and add a form names "menu.xaml" VS crashes ("could not fine new element in hierarchy...). It seems to be form name dependent. Sometimes it works (for example, if I use Page1, the default).

When it works, after adding the page, it won't compile. Says "the name InitializeCompoent does not exist in current context. This is pretty basic stuff I am trying to do.

I feel like I am missing something (wrong version, missing packages, etc). i am trying to follow the examples from Xamarin University but they don't match and nothing seems to work right. I looked at NuGet package updates, but none seem to apply.

Help?

Answers

  • BenjaminTooleBenjaminToole USMember ✭✭✭

    Make sure when renaming files your right clicking on the filename and selecting rename that way. You may need to manually update your .xaml file name as well. Also check you .xaml file, in the header at the top check that the 'Class' field equals your .xaml.cs file name and path.

    I feel your pain. Starting out, just keep digging and asking questions as you need. You'll start rolling soon enough!

Sign In or Register to comment.