I can not add Apple Developer Account (Apple ID) to Visual Studio Mac 7.3

I am getting the following error in the ide.log:

[19:11:43]: [33mGet started using a Gemfile for fastlane https://docs.fastlane.tools/getting-started/ios/setup/#use-a-gemfile[0m
Credential ****appleid****:************* added to keychain.
INFO [2017-12-07 19:11:52Z]: Syncing ****appleid**** developer info...
INFO [2017-12-07 19:11:55Z]: Syncing developer teams
INFO [2017-12-07 19:11:56Z]: Processing details of ****team**** team...
WARNING [2017-12-07 19:27:54Z]: Gtk-Warning: Can't set a parent on widget which has a parent

Stack trace:
at Gtk.Widget.gtk_widget_set_parent (System.IntPtr , System.IntPtr ) [0x00000] in <861b978b87fe48cdaecc06b6d5833139>:0
at Gtk.Widget.set_Parent (Gtk.Widget value) [0x00022] in /Users/builder/data/lanes/4992/mono-mac-sdk/external/bockbuild/builds/gtk-sharp-None/gtk/generated/Widget.cs:58
at Mono.Addins.Gui.AddinManagerDialog.OnShown () [0x00006] in /Users/builder/data/lanes/5402/ff055b3e/source/monodevelop/main/external/mono-addins/Mono.Addins.Gui/Mono.Addins.Gui/AddinManagerDialog.cs:189
at Gtk.Widget.shown_cb (System.IntPtr widget) [0x00010] in /Users/builder/data/lanes/4992/mono-mac-sdk/external/bockbuild/builds/gtk-sharp-None/gtk/generated/Widget.cs:957

****appleid**** is my apple id email address and ****team**** is my team name.

I have tried to reinstall fastlane and have also tried reinstalling VSMac with no change.

I have tried all the trouble shooting things listed here:
https://developer.xamarin.com/guides/cross-platform/macios/apple-account-management/

I can see that the error could be related to the known issue of the VS window not getting focus back, but I have tried now several times as suggested and it still does not work.

I know that I have to enter my computer login credentials when the deliver.* dialogs popup and just click allow all, I am doing that.

So is this a bug or am I doing something wrong ?

Best Answers

Answers

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    Just want to add that it is working fine in Xcode. Here I can add Apple Developer Account and see my team and certificates.

    I have checked fastlane and it is working fine. I am running latest fastlane v2.68.2

    This problem is keeping me from distributing my app via both AdHoc and AppStore.

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    Update: If I reopen the Preferences and the Apple Developer Accounts setting I get the follow error:

    "Failed to synchronize ****personal email**** teams with Apple Developer Portal"
    "Password for account ****personal email**** was deleted from Keychain. Please remove and add this account again."

    Where ****personal email**** is my primary email address used with the Apple ID. It is however not the Apple ID email login.

    When I click OK to this dialog box I can see that it has loaded an Apple Developer Account with my ****personal email**** instead of the current Apple ID email used for my Apple Developer Account.

    If I close and reopen VSMac the error comes again. So only thing I can do is remove the failing account as requested and try again with same error.

    Again, this works fine in Xcode with no problems here.

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    Here are some screen shots of what I am experiencing:

    I start by clicking add new Apple Developer Account and get the login dialog where I enter my Apple ID credentials:

    I then get the "deliver.*" keychain authentication dialog where I enter my computer login password and click Allow Always (sorry it is in danish):

    And then nothing happens, I am left with a blank Preferences list for Apple Developer Accounts ??

    If I then close Preferences and open it again I get this:

    The Apple ID is displayed wrong with my primary email address instead of the Apple ID email. This works in Xcode, here Xcode displays it corrects with the Apple ID email.

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    Here is my logs from VSMac:

  • AmyBAmyB USXamarin Team Xamurai

    @PerHungebergMller Sorry to hear that you're having issues. It does sound like a bug, could you please file an issue on developer community: https://developercommunity.visualstudio.com/spaces/41/index.html

    In the meantime, I'll raise this to the attention of our engineering team. Thanks!

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    @AmyB Hi Amy, I already found a similar issue from some one else on the developer community site:

    https://developercommunity.visualstudio.com/content/problem/159756/cant-add-apple-developer-account-vs2017-722.html

    I could report it as a bug using your bugzilla system if you want?

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭
    edited December 2017

    @Oleg_Demchenko Hi Oleg.

    I created my Apple ID a long time ago when Apple had there mac.com web site before it was recreated as iCloud.

    So my Apple ID is an email address for mac.com domain called villakulla at mac.com. However in the Apple ID I have set the primary email address to be my private email address, hence the double email addresses.

    But Xcode does not seem to have any problem with this and I actually haven't had any problems before with Xamarin Studio as I recall, but that was before the new fastlane stuff.

    I hope you find a way to solve the issue, since I would like to avoid having to switch to a new Apple ID just for this.

    Thank you for the tip on AdHoc and AppStore distribution, I will check that out.

    Regards,
    Per

  • I am also having the exact same problem. My Apple ID for my Apple developer account is a very old ID that is not even an email address. After I add my Apple ID to Visual Studio for Mac, it can't find my password in the Keychain because it tries to use my contact email address instead, which is different from my Apple ID.

  • This is happening to me too. I've tried removing the Key Access keys, and it allows me to "try again", however, it cannot authenticate against iCloud and other apps like XCode work fine.

  • All, I found I was entering my AppleID password in the 2nd prompt, when it was my MAC OS account password it was asking for.

  • ShawnCastrianniShawnCastrianni USBeta ✭✭✭
    edited January 2018

    I have all the same symptoms, but I do not have a mismatch in my appleid and contact email. The ide.log simply shows it is processing details of "XXXXX" team... and never does anything after that.

    Before the integration of fastlane and apple developer accounts, I simply used developer.apple.com to manage everything and downloaded the prov profile. Then I just double clicked the prov profile in Finder and XCode launched and did something. I then exited XCode and my prov profile was installed/updated. Visual Studio for mac could then see installed/updated prov profile and everything was good. Now, double clicking the prov profile does NOT seem to make it available to Visual Studio for mac. I am stuck!

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    Hi @Oleg_Demchenko, Is it possible to install the preview and then revert back to the previous version ? Or even better, can I install the preview next to my existing setup ? I would like very much to avoid messing with my existing setup.

  • Oleg_DemchenkoOleg_Demchenko RUMember ✭✭

    @PerHungebergMller that's a reasonable concern. Let me check with our IT team. Maybe we can setup a VM for you.

  • ShawnCastrianniShawnCastrianni USBeta ✭✭✭

    @Oleg_Demchenko Do you have any suggestions for me? I do not have an old Appleid but I still can't add it to VS for mac. The ide.log just hangs on processing team.

  • Oleg_DemchenkoOleg_Demchenko RUMember ✭✭

    Hi @ShawnCastrianni,

    Sorry for the delay. Could you provide repro steps, the IDE log, and environment info?

    When you double click provisioning profile it's copied by Xcode to "/Users/username/Library/MobileDevice/Provisioning Profiles" folder.

    Here are some reasons why provisioning profile might not be available in Visual Studio Mac:
    1) Provisioning profile doesn't match certificate(s) installed in Keychain.
    2) Provisioning profile doesn't match certificate selected in "Signing Identity" drop-down in iOS Bundle Signing options.
    3) Provisioning profile doesn't match bundle identifier of your app (or doesn't match wildcard patter if you use a wildcard profile).

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    @Oleg_Demchenko, please try to create a new apple ID where you get a new icloud email address. Then set your primary email address on the apple ID account to something other than the new icloud email.

    That should give you the same apple ID senario that I have. So your apple ID will have a name like [email protected], but the primary email address on the apple ID will be some other email (must be a working email).

    My apple ID is called villakulla"at"mac.com and my primary email is then my personal email address. The apple ID is also an email address that then just points to my primary email.

    Best regards,
    Per

  • mkeevymkeevy Member

    Hi All,

    I too have the same issue. My appleid and email address are not the same etc. Works in XCode as others have stated etc. Is there a fix for this yet?

    Thank you.

  • mkeevymkeevy Member

    Hi All,

    Just a quick update. It seems I was able to work around the issue by manually adding my signing identity and provisioning profile data under "Options > iOS Bundle Signing." for the relevant platform. Check out the Visual Studio 2017 for Mac release notes for ver 7.1.0.1297 for details on how to do this.

    Sorry but I couldn't post the link as I am not allowed to, but I am sure you'll find it.

    I hope this might help someone else.

    Thank you.

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    @Oleg_Demchenko I have been able to test the VS preview 7.5.x you linked to on another mac, and I can confirm that it works with my apple id :-)

    I have not done any development testing, like opening projects and compiling, deploying etc. I have only tested that I could add my apple developer account with the new process that installs fastlane first in the background (nice).

    I can see the details of my apple developer account and it all checks out and is the exact same as seen in Xcode.

    So again, the problem I reported in this thread seems to be solved with this version 7.5.x of Visual Studio_for Mac.

    Thank you.

  • Oleg_DemchenkoOleg_Demchenko RUMember ✭✭

    Hello @PerHungebergMller,

    Thank you so much for filing this issue and leading the further investigation of the problem. The fix should be available in Visual Studio Mac published in Alpha channel and soon it will hit the stable.

    Oleg

  • nivibhatnivibhat Member ✭✭

    I have the issue to add developer account on VS mac. I enter appId, password and nothing happens, a blank screen. Is there a way to fix this problem?

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    @nivibhat Yes upgrade to VS Mac 7.5.x, then it should work.

    Remember that you may have to log into your Apple developer account and agree to a new license agreement for all things to work.

    Regards,
    Per Hungeberg Møller

  • nivibhatnivibhat Member ✭✭

    @PerHungebergMller - thank you.
    Upgrading to VS Mac 7.5.1 and restarting the machine helped. Appreciate your help.

  • nivibhatnivibhat Member ✭✭

    @PerHungebergMller - When I connect the iPhone to debug, i am getting the error "Automatic provisioning failed." And I see that I am automatically logged out of my developer account. If I try to login back, I get error " Failed to synchronize
    appId teams with Apple Developer Portal.
    I have the valid provisioning profile which has this iPhone added to it. . any thoughts. Thanks much

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    @nivibhat I have not tried this myself yet since I have mostly used VS 2017 on Windows for App dev.

    But you can check the log file in the help menu in VS Mac to see if this gives any more information.
    I could be a bug in VS Mac. I know they are working on some extra automation around provisioning profiles. There is a version 7.6 in the beta channel with some of this I thing that you could try out if you feel lucky.

    Its important that your profile files in the folder /Users/(user)/Library/MobileDevice/Provisioning Profiles match the profiles you have in your developer account.

    Regards
    Per

  • SuatKorkmazSuatKorkmaz USMember ✭✭✭

    None of the workarounds above worked for me. I have the latest stable of VS Mac (7.5.1). I'm trying to add my account via VS but I get this error:

    Failed to synchronize ... account with Apple Developer Portal.

    Unexpected authentication failure. Reason: {
    "authType" : "non-sa"
    }

    I was able to add the account to xCode but I'm stuck in VS.

  • PerHungebergMllerPerHungebergMller DKMember ✭✭✭

    @SuatKorkmaz Interesting, looks like a new bug, maybe you @Oleg_Demchenko should have a look at that.

    @SuatKorkmaz Just to rule things out, if you have access to another Mac, try and see if the error is the same here.
    And if you feel really lucky you can delete the deliver.* internet access codes that VS Mac creates (I think) as part of this process.
    You can access the deliver.* access codes via your keychain app on the Mac. Search for "deliver.", then delete them and try logging into your account in VS Mac again.

    But it sounds like some kind of bug since you have it working in Xcode. Xcode and VS Mac should be in sync on this always.

    /Per

  • Oleg_DemchenkoOleg_Demchenko RUMember ✭✭

    @PerHungebergMller, thanks for standing the ground and advising fellow developers on the issue!

    @SuatKorkmaz, please refer to this comment for more information about how to solve the auth problem.

    In a nutshell, you have to accept Apple's privacy agreement on Apple ID management portal or in iTunesConnect.

    @nivibhat, for me to investigate the problem, could you please provide the following?

    1. If possible, a screencast showing the issue, and steps to reproduce
    2. Logs from Help > Open Log Directory
    3. Full version details from Visual Studio > About Visual Studio > Show Details > Copy Information [button]
  • JassimRahmaJassimRahma USMember ✭✭✭✭

    I am trying to add Apple ID on Visual Studio for Windows from The Tools->Options->Xamarin->Apple Accounts

    But when I enter the Apple ID and Password it will just be frozen forever

    How can I fix this Please

    Thanks,
    Jassim

  • BobTitularBobTitular USUniversity ✭✭

    @Jassim - I had the same problem this morning. Then I realized that my VS2019 wasn't connected to my Mac. Once I connected to my Mac, I was able to add my Apple Id account.

  • myPhoenixmyPhoenix ZAMember ✭✭

    This is still an issue and it seems like Xamarin / Microsoft dont really give a damn about it. Does anyone else have a work around to get logged into fastlane/VS2019

  • rnhassanrnhassan Member

    I am facing the same issue all of a sudden. I am not able to add Apple Account (Xamarin >> Apple Account). Using Visual Studio Community 2019 on Windows 10 Pro. Enter apple account credentials and the operation never ends....

  • ryanbueningryanbuening Member ✭✭
    edited November 19

    @rnhassan I'm having the same issue. I try to login and nothing happens. Just sits and spins.

    I'm using Visual Studio 2019 16.3.9

Sign In or Register to comment.