Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Cannot run iOS simulator for iOS 11.1

JonasRembrattJonasRembratt SEUniversity ✭✭✭
edited December 2017 in Xamarin.iOS

Since a few weeks now I haven't been able to deploy and execute apps on iPhone simulator running on iOS 11.1. The problem seems related to XCode or, possibly, MacOS because I get the same error when I try deploy from XCode (using Swift). This is the error message I get:

Unable to lookup service com.apple.CoreSimulator.host_support: 0x3

I have tried running on iOS 10.0 and also 11.1 on iPhone 6 and that works fine. But iPhone 8 or 7 on 11.1 yields this error.
Can someone help me decrypt the error message (Google came up empty).

Answers

  • seanydaseanyda GBMember ✭✭✭✭✭

    @JonasRembratt said:
    Since a few weeks now I haven't been able to deploy and execute apps on iPhone simulator running on iOS 11.1. The problem seems related to XCode or, possibly, MacOS because I get the same error when I try deploy from XCode (using Swift). This is the error message I get:

    Unable to lookup service com.apple.CoreSimulator.host_support: 0x3

    I have tried running on iOS 10.0 and also 11.1 on iPhone 6 and that works fine. But iPhone 8 or 7 on 11.1 yields this error.
    Can someone help me decrypt the error message (Google came up empty).

    Not familiar with the error message, but keeping the xCode and the OS X up to date always seems to solve all my simulator deploying problems.

  • JonasRembrattJonasRembratt SEUniversity ✭✭✭

    Since having updated to latest version of Visual Studio the problem seems to have been resolved.

Sign In or Register to comment.