Devices not showing up in Android Target Device Dropdown

I'm not sure where the breakdown is happening, but as of yesterday I can no longer see ANY devices in the Android Target Device DDL. I've gone as far as to uninstall and reinstall Xamarin, but it doesn't seem to have made any difference.

What do I need to do to get it back? Right now I'm doing all my coding in VS and then using Xamarin Studio to deploy to my Nexus 4.

Also, the Emulator Manager does have definitions that I was previously using, and as I said, I AM able to deploy to my Nexus 4 and Nexus 5 from Xamarin Studio running on the same VM.

Posts

  • ChaseFlorellChaseFlorell CAInsider, University mod

    Interesting development. I launched a DIFFERENT project and the ddl is back. It appears to only be missing in our primary project.

    I'm wondering if there's any info contained in the .csproj file.

  • ChaseFlorellChaseFlorell CAInsider, University mod

    Turns out the problem was that I had removed my App as a "Startup Project".

    To fix this, just right click on your Android Project and select "Set as Startup Project".

  • MichaelZinoMichaelZino CAMember

    Thanks Chase, lost about 30 minutes on this. I agree this should work regardless. I just wanted to Deploy the app, not running it.

  • KrumelurKrumelur DEUniversity ✭✭

    Doesn't work for me. My Nexus 7 just won't show up. Works like charm in XS on the Mac but no luck with VS. Tried on two different machines.

  • ChaseFlorellChaseFlorell CAInsider, University mod

    @Krumelur another way to get it to work AFTER you set the Droid app as Startup, is to pull the shade down on your device and touch the "Connected As ... " item. In there, just switch from MTP to PTP, or Vice Versa.

  • NealCulinerNealCuliner USBeta ✭✭✭

    Can't get my Nexus 7 (KitKat on windows 8.1/VS 2013) to appear either. Using XamAndroid.Latest

  • SergiuCosminSergiuCosmin USMember ✭✭

    hello, I have the same problem, I have a Galaxy Nexus and it worked fine yesterday, then today I rebooted my device and it does not appear anymore on the Target Android Device dropdown list, I am using VS2013 Update2 RC with latest Xamarin on Windows 8.1 update 1

  • GlenOliffGlenOliff USMember

    Thanks so much @ChaseFlorell‌! I just upgraded from an earlier version of Xamarin, and couldn't get the Target Device DDL to show anything - even though invoking "adb devices" clearly showed my device. Super helpful, thanks again!

  • To get my devices recognised, I needed to go into the phone, untick the "USB Debugging" checkbox on the Developer Options screen, then re-tick it.

    Windows 7 would then start installing drivers (3 of them, for my Samsung S3), and it was important to get all 3 got installing correctly. Once this was done, I could run the "adb drivers" command, and see my device.

    One last step: I now needed to _quit _VS2013, and go back in, for my device to show up in Xamarin's drop down list.

  • BenGeislerBenGeisler USMember

    A junky USB cord can also cause this problem. It took me a while to figure this out since the PC "sorta" recognized the device but won't show it in the list of devices. Once I replaced the cable it worked.

  • When this happens to me it is usually because USB debugging has disabled itself for some reason. Make sure it is enabled.

    Also, check that the Android project is set as the Startup project. It would be cool if Xamarin eventually came up with a unified launcher where you could specify profiles to reduce the friction of switching between projects.

    Also, if the device was plugged in before Visual Studio starts, I've found that you sometimes have to unplug and reattach the device.

    In addition, after upgrading either Visual Studio or Xamarin on the Mac Build host, I've found it is best to de-pair the build host on the mac and re-pair it with VS.

  • JimmieRussJimmieRuss USMember

    Thanks @ChaseFlorell‌. I ran into this after upgrading to a new phone mid project. Switching between MTP and PTP worked for me. It appears it's just the act of switching between the two that "shakes things loose" and causes the certificate for debugging prompt. After that, things starting working like a charm.

  • Sreekanth_BantuSreekanth_Bantu USMember ✭✭
    edited June 2015

    Thanks @Jimmie Russ, after switching between MTP & PTP my device (Samsung S4) detected.

  • I'm having a lot of trouble with this. I just cannot get my LG phone to show up as a debug option in Xamarin for OS X. I've installed the driver from http://www.lg.com/us/support-mobile/lg-LGVS450PP, tried different USB cables, turned developer options on and off, changed between connection modes, downloaded more packages from Android, and on and on.

    When I plugin the phone in it mounts on my Mac as a CD ROM, and then goes away after 30 seconds or so. That may have something to do with it?

    I'm a learning developer, and could really use some input here. Any ideas?

  • ScottNimrodScottNimrod USMember ✭✭

    My device only shows up if I connect it to my USB hub and then connect the hub to my machine.
    My device does not show up when I attempt to connect it directly to my machine.

  • PeerlessProgrammerPeerlessProgrammer USUniversity ✭✭

    I know this is an old post but still seems relevant. Had trouble connecting a Droid Turbo in Visual Studio 2015 on Windows 10. I had to download and install the Motorola Device Manager to get the USB drivers. You have to also enable Developer Mode of course.

    http://www.verizonwireless.com/support/knowledge-base-117727/
    https://motorola-global-portal.custhelp.com/app/answers/prod_detail/a_id/103535/p/30,6720,9277

  • Michael's comment helped me.
    Guys if you USB debugging is enabled on your device and still you dont see your device then try installing your device drivers on your machine.

  • AlejandroPrezAlejandroPrez USMember

    I tried everything in this post... nothing worked.

    I had to update my Windows... once the +1hour update finished, the device was "installed" properly, detected and showed in the dropdown.

    Good luck

  • Narendra.2973Narendra.2973 USMember, University ✭✭

    Whenever this happen, i have to open xamarin sample project and then restart my project. The device again back started showing in my project :smile:

  • PaulGaunardPaulGaunard LUMember
    edited June 2016

    For "Windows on Intel" users, its worth mentioning that Intel provides dedicated "USB for Android Devices" drivers, available at https://software.intel.com/en-us/android/articles/intel-usb-driver-for-android-devices

    Using Visual Studio 2015 Community Edition on Windows 8.1, I did try all the tips & tricks I found on this forum or StackOverflow to have my Acer Liquid Zest detected, without success. And then I found those drivers, that worked perfectly, at least for my configuration.

    Hope it helps !

    Paul

  • ShankarBandaruShankarBandaru USMember

    I had this problem as well, it was not working for me as I didn't had the device sdk version loaded. Load the required sdk using the Android Sdk manager.

  • faceoffers28faceoffers28 USUniversity ✭✭✭
    edited December 2016

    I can't get my new Samsung Galaxy Tab E to connect to Visual Studio 2015 Enterprise with Update 3 on Windows 10. My device is running Android 6.0.1. Samsung Kies would not connect, so I downloaded and installed Samsung Smart Switch. I still can't get the device to show in the drop-down. #fail

    http://www.samsung.com/us/support/owners/app/smart-switch

    I am running Xamarin.Android 6.0.4.0 and Xamarin 4.0.4.4.

    The app is compiled with API 23. (6.0 – 6.0.1 Marshmallow released October 2015)

    My Samsung Galaxy 3 running Android version 4.4.2 (KitKat) connects just fine.

    My Alcatel onetouch running Android 5.1.1 (Lollipop) connects just fine.

    UPDATE: I finally got it to work by turning on USB Debugging Mode.

    https://www.verizonwireless.com/support/knowledge-base-180117/

  • ZeidShubailatZeidShubailat JOMember
    edited February 2017

    Hello,
    I'm new but may have some info as I ran into a few things trying to setup my Nexus 6P to work. Long story short, when I use "adb.exe devices -l" I can now see the Nexus connected. Issue is that I cannot see the device in the drop down list to start debugging and as many of you mentioned, I also have issues where an AVD that I created also stops showing. (For the AVD device to work, it seemed that if I start it up and then start the project, I would start seeing it. )

    The issue first was just to get Windows 10 to install the right device driver as it initially setup the Nexus 5P as an Acer device.

    First I had to make sure that I remove anything that was "Acer" so that I start from scratch and that was done through device manager by double clicking on the devices an uninstalling the driver (in my cases I also checked to box to remove the drivers from the PC)

    Once that was done I followed instructions here as the driver .inf file downloaded through the SDK manager didn't have the hardware signature of the NEXUS 6P (with Android 7.1.1)

    **Please read notes below the link as there are some items to take into consideration **

    http://blog.kikicode.com/2013/10/installing-android-adb-driver-in.html

    Notes about the above:

    • There are two different hardware profiles for the device when it is running in developer and debugging mode turned on and when it is running as storage meaning you will get a different ID when following the instructions if debugging is off or on. Make sure debugging is turned on to get the right hardware ID
    • Once you want to edit the inf file; you must be in administrator mode (at least I had to) so I ran the cmd prompt as an administrator, went to the file locations of the Google USB drivers and ran notepad.exe from the cmd prompt (note, I'm logged into my machine as part of administrators but unless I went through the elevated cmd prompt way I was not able to save the file) - if someone knows why the OS does this, I'm interested in knowing
    • The instructions about turning off the need for integrity checks and device signature were not correct - the right way of doing it is here: https://www.technipages.com/enable-disable-device-driver-signing

    Once all this was done, what I had was an Adroid Composite ADB Interface showing up under Android Device in the device manager when I connected the Nexus 6P with Debugging Turned On

    Now, when I go to the ADB command prompt and run "adb devices -l" I can actually see that the device listed

    ... but alas, still can't see my device in the drop down debug list... while I was in the beta program for Nougat, perhaps there's an API incompatibility (?)

    Update- needed a Xamarin update it seems - (Tools-> Options-> Xamarin-> Other -> check now). A rookie mistake I suppose

  • ArchanaPatelArchanaPatel USMember

    Similarly I am facing with my Redmi Note 3 device, It is not visible on run with devices list in VS. please help

  • AshleyGazichAshleyGazich USXamarin Team Xamurai

    @ArchanaPatel

    This thread is quite old and may not be relevant for the issue you are having. For troubleshooting a new scenario that is not resolved by the steps earlier in this thread, I would recommend creating a new forum discussion or question. If you have not already done so, please work through Set Up Device for Development. Thanks!

  • JordanMaxJordanMax USMember ✭✭

    @ChaseFlorell said:
    @Krumelur another way to get it to work AFTER you set the Droid app as Startup, is to pull the shade down on your device and touch the "Connected As ... " item. In there, just switch from MTP to PTP, or Vice Versa.

    This worked for me. I did everything else too with no luck. (enable debugging, restart VS2015, Restart ADB server..etc). My issue was that the device wasn't even showing in adb devices

  • thilde09thilde09 DEMember

    @Krumelur another way to get it to work AFTER you set the Droid app as Startup, is to pull the shade down on your device and touch the "Connected As ... " item. In there, just switch from MTP to PTP, or Vice Versa.

    That worked for me and installing Android USB Driver. Cheers!

  • mrnoelmrnoel USMember

    Also check the Minimum Android Version in the AndroidManifest.xml is lower or equal to your device.

  • peshopesho Member

    On windows 10: after android studio update simply restart the PC.

  • praveenaHMpraveenaHM USMember ✭✭

    AbhijeetMahajan.8995 your comment helped me.
    You saved my research time thank you so much...

Sign In or Register to comment.