How do I fix 'deployment errors' ?

I'm running a fresh install of Visual Studio 2017 with Xamarin with my Android SDK fully updated as well as the NuGet Packages. I have my Android phone connected with USB debugging enabled and the ADB recognizing it properly, and visual studio recognizing it, when wanting to debug. I've created a blank Xamarin forms app and when trying to run it on my Android phone, the build succeeds but the deployment fails, giving the pop-up "There were deployment errors. Continue?"

Best Answer

  • HoodHookHoodHook NL
    Accepted Answer

    I was able to solve the problem by unchecking "use shared runtime" in the android options of the project

Answers

  • AbidButtAbidButt USMember ✭✭

    Try to deploy a blank page and go one by one. I had the same issue then found that there were spelling mistakes...

  • HoodHookHoodHook NLMember
    Accepted Answer

    I was able to solve the problem by unchecking "use shared runtime" in the android options of the project

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    Can you please provide a diagnostic build output and any logs from the Output pane when attempting to Deploy?

  • mostafa90mostafa90 USMember ✭✭

    Hi,
    In my case the Keystore path was wrong, deployed successful after fixing the path.

  • PonrajPonraj Member

    @HoodHook said:
    I was able to solve the problem by unchecking "use shared runtime" in the android options of the project

    i am also unchecked but not solved. any query

Sign In or Register to comment.