App Store iOS app startup crash in device ios 11.1.1

RushAidRushAid USMember ✭✭

Hello developers,

I have developed Android and iOS app and submitted to Google Play and App Store. On Google Play it works just fine. However in App Store, the app keep crashing on startup in OS 11.1, but works fine on other os.

I managed to solve the problem by deleting the unused NuGet Packages, Component, References, deleting the /obj and /bin folders, clean up and restore all NuGet Packages. Then I test debug on physical device iPhone 6 Plus running iOS 11.1 and the app works fine. The app also works fine on simulator running iOS 11.1, so I submit the new .iso file to the App Store.

Recently, after the app reviewed by the App Store, the app crash on startup in OS 11.1.1. Previously it crash on OS 11.1 and now it crash on OS 11.1.1. The crash log from App Store are also provided below. I have tried to symbolicate the crash logs but no useful information obtained.

I have read that there are many issues regarding the released os 11 by Apple, so I understand many of developers may face the same-related problems . Can you all suggest me what to do? or maybe suggest a suitable link for symbolicate the crash logs?

Best Answer


  • RushAidRushAid USMember ✭✭

    Hye @JohnMiller,
    Sorry for the late reply. It's been a though day.

    I have tried to symbolicate the crash using Xcode, but there is no crash logs in both simulator and device, because the crash is from Apple Store. So I move to the 2nd option using terminal.

    It says to collect (.crash, .app, .dSYM) files that correspond to the same builds. I have collect the crash and dSYM file, but what is the .app file? Is it the .ipa file that I uploaded to the App Store?

  • RushAidRushAid USMember ✭✭

    Nevermind, figure out the .app by converting .iso file to zip and extract it.

    Below is the symbolicated log file. Guest I have to stare at the intricate coding for days to find some useful information. XD

  • RodneyWillisRodneyWillis USMember ✭✭

    BTW...I'm having the same issue. Crashes immediately at startup, but only when downloaded from app store.

  • JassimRahmaJassimRahma USMember ✭✭✭✭

    My problem is different.

    The app is beautifully working on my Visual Studio for Mac but crashing upon starting on TestFlight...!

    How troubleshoot in this case?

Sign In or Register to comment.