Forum Xamarin Xamarin Test Cloud (Read Only)

VSTS TestCloud -> Not a valid device selection

Hi,

I've tried a lot of time (and forced to buy a VSTS Hosted Pipeline because of this tests, I've no more Hosted hours).

I'm unable to submit a valid testcloud UITest :

  • I've tested my UITest on my local machine : OK
  • I've got a Xamarin Testcloud account with "hours" to spend : OK
  • I've done my build process in VSTS and by disabling the TesCloud Task, all is OK.
  • I've search for "TestCloudAgent", but it seems that on Android it doesn't exists (just iOS right ?)

I just want to try to make my UITest works on my CI/DI pipeline with an android application and just one physical device (Samsung Galaxy Tab4 10.1).
Nothing helping me on google...

The VSTS logs show me that there is a "Not a device valid selection", but all the steps before are running well :

d:\a\3\s\Sources\packages\Xamarin.UITest.2.2.1\lib\tools\test-cloud.exe submit "d:\a\3\b\Release\com.respawnsive.marchedigitale.apk" XXXXXXXXXXXX --user [email protected] --devices 6d65141e --series "master" --locale "fr_FR" --assembly-dir "d:\a\3\b\Release\test-assembly" --nunit-xml "d:\a\3\b\Release\test-assembly\xamarintest_111.0.xml"

All Uploads seems to be good, the last is :
Uploading AndroidTestServer.apk... 100%

And the error :

Upload failed. Response:
Status: 400
Contents:
{"error_message":"\nNot a valid device selection. No active device selected supports your app.\nMake sure your app contains the most recent Test Cloud Agent\n"}
System.Exception: Unexpected exit code 15 returned from tool test-cloud.exe
at Microsoft.TeamFoundation.DistributedTask.Task.Internal.InvokeToolCmdlet.ProcessRecord()
at System.Management.Automation.CommandProcessor.ProcessRecord()
PowerShell script completed with 1 errors.

I've tried a lot of times to go to Testcloud.xamarin.com, to choose a new test run, to copy the "device" (is it normal that it changes everytime ?) and past it in my VSTS Tescloud Task...

Anybody has an idea ?

Thanks in advance

Sign In or Register to comment.