Forum Xamarin Xamarin Test Cloud (Read Only)

App not installing with Xamarin Test Recorder

I have a Xamarin Forms app for which I am trying to create some UITests. I'm trying to use the Xamarin Test Recorder (Mac environment). I can start the Test Recorder, select my device and my IPA file but I keep getting an error back stating 'App Installation Failed - Failed to install app to device'.

I've built the code locally on my Mac and signed it. I've pointed the Test Recorder at the generated IPA file.

Any ideas greatly appreciated.

Answers

  • PeterSimonsPeterSimons GBMember ✭✭

    Hi steve,

    What device, iOS version, UITest Package version and Testcloud.Agent package version?

  • SteveDixSteveDix USMember ✭✭

    @PeterSimons said:
    Hi steve,

    What device, iOS version, UITest Package version and Testcloud.Agent package version?

    TestCloudAgent: 0.21.3
    UITest: 2.2.1

    Tried simulator - iPhone 8 iOS 11.1 and also physical device iPhone 6 Plus 10.3.3

  • PeterSimonsPeterSimons GBMember ✭✭

    Assuming you're also on Test recorder Version 1.2.6 (1.0)

    you'll need to build the app in debug so it produces an *.app file and then in the test recorder choose to open that file

  • SteveDixSteveDix USMember ✭✭

    @PeterSimons said:
    Assuming you're also on Test recorder Version 1.2.6 (1.0)

    you'll need to build the app in debug so it produces an *.app file and then in the test recorder choose to open that file

    Works to an extent.

    Get an error in the Recorder stating:

    Failure connecting to app
    Failed to launch simulator
    Exit code 134
    iOSDeviceManager[22842:2716063] Failed to private frameworks for FBSimulatorControl with error Error Domain=com.facebook.FBControlCore Code=0 "Attempting to load a file at path '/Applications/Xcode.app/Contents/Developer/Library/PrivateFrameworks/CoreSimulator.framework', but it does not exist"

    Any ideas?

  • Hi All! Do you have any update on this? I'm getting the same error:

    Failure connecting to app
    Failed to launch simulator

    ExitCode: 134
    2018-02-01 11:25:45.836 iOSDeviceManager[6602:1833179] Failed to private frameworks for FBSimulatorControl with error Error Domain=com.facebook.FBControlCore Code=0 "Attempting to load a file at path '/Applications/Xcode.app/Contents/Developer/Library/PrivateFrameworks/CoreSimulator.framework', but it does not exist"

  • NipunKalraNipunKalra USMember ✭✭

    Hi @VanesaIavarone, I was facing the same problem running the Xamarin Test Recorder.
    But after @PeterSimons mentioned above the version of Test Recorder, I went back to see my TR version. After updating to 1.2.8 all the errors gone & I am able to run the Xamarin Test Recorder. Give it a try. When you are on update page select Weekly from the Update channel dropdown. Cheers

Sign In or Register to comment.