Build error as soon as I add references to a new nuget package

Hey, this bug happens on both- Android and iOS for me.
When creating a clean project (shared codebase, xamarin.forms) the live player functionality is working great.

As soon as I try to add (in my case) the references to Microsoft's App Center with "using Microsoft.AppCenter;" the build fails throwing:

The type or namespace name 'AppCenter' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?)

The code recognizes the reference and a local debug build is successful.

Tagged:

Posts

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Have you tried to stop and re-start the live player app after adding nugets?

  • Yes, I also restarted the computer and reloaded the projects. I will try to install and uninstall the packages again.

  • Ok so this still doesn't work after reinstalling the packages. Is this error reproducible?

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Ahh this has been reported with AppCenter NuGets. We have a fix in place currently and will be pushing out a new build soon.

  • EternalBardEternalBard BRBeta ✭✭

    Hi @JamesMontemagno Is this fix published? I'm trying to add this nuget to a new project an there's no .AppCenter here. I don't know if I'm missing something. Thanks.

  • Dayakumar.3395Dayakumar.3395 INMember ✭✭
    edited January 2

    After package update 1.12.0
    I'm getting error about import package:
    using Microsoft.AppCenter;
    using Microsoft.AppCenter.Analytics;
    using Microsoft.AppCenter.Crashes;

    Better to use the lower version, it seems like Microsoft issue.

Sign In or Register to comment.