Deployment failed:Mono.AndroidTools.InstallFailedException: Failure [INSTALL_FAILED_NO_MATCHING_ABIS

Hello Guys,
I have just created a project in xamarin visual studio 2015 .I am able to build in debug mode , But in release mode it shows following error Because of this there is no apk generated in release mode. Please help me in this.

2>G:\test\android-sdk\build-tools\26.0.0-preview\zipalign.exe 4 "G:\Learning Hub\Xamarin79_85\DesignLibrary_Tutorial\DesignLibrary_Tutorial\bin\Release\DesignLibrary_Tutorial.DesignLibrary_Tutorial-Signed-Unaligned.apk" "bin\Release\DesignLibrary_Tutorial.DesignLibrary_Tutorial-Signed.apk"
2>:Deployment failed
2>Mono.AndroidTools.InstallFailedException: Failure [INSTALL_FAILED_NO_MATCHING_ABIS]
2> at Mono.AndroidTools.Internal.AdbOutputParsing.CheckInstallSuccess(String output, String packageName)
2> at Mono.AndroidTools.AndroidDevice.c__AnonStoreyD.<>m__0(Task1 t) 2> at System.Threading.Tasks.ContinuationTaskFromResultTask1.InnerInvoke()
2> at System.Threading.Tasks.Task.Execute()
2>Deployment failed because of an internal error: Failure [INSTALL_FAILED_NO_MATCHING_ABIS]
2>InternalError
2>Build succeeded.
2>Deploy successfully on 5" Marshmallow (6.0.0) XXHDPI Phone
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 1 succeeded, 0 failed, 0 skipped ==========

Please help me in this .
Thanks.

Best Answer

  • AndyVWattAndyVWatt US ✭✭
    Accepted Answer

    After searching a lot on internet ,
    properties -> android options ->advanced ->supported architectures -> marking both armeabi-v7a & x86 checked with configuration in release mode solved my problem.

Answers

  • AndyVWattAndyVWatt USMember ✭✭
    Accepted Answer

    After searching a lot on internet ,
    properties -> android options ->advanced ->supported architectures -> marking both armeabi-v7a & x86 checked with configuration in release mode solved my problem.

Sign In or Register to comment.