Forum Xamarin.Android

Issue updating Android support library

Rexar5Rexar5 USMember ✭✭

I'm having an issue updating my Android support library through NuGet package manager. I go to the updates section and click the button and I get the error below:

"Could not install package 'Xamarin.Android.Support.v4 26.1.0.1'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v7.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author."

The minimum version of the update is monodroid 8.0, so in order to resolve this, I updated the values in my project and Android Manifest to target Android 8.0. To do this I right clicked my project and went to properties. Then I updated the "Compile using Android Version" option in the Application tab and the "Target Version" option in the Android Manifest tab to 8.0. I did a full clean and rebuild. Then I opened NuGet again and it is still failing to install because of the above error claiming I am targeting 7.0.

Has anyone else encountered this issue?

Thanks!

Best Answer

Answers

  • Rexar5Rexar5 USMember ✭✭

    Thanks, that did it! I guess the IDE wasn't correctly updating the file.

  • So I am having the same problem. But when I go to Project Properties -> Build -> General I don't see a Target Framework. Any ideas on what I am doing wrong?

    Thanks!

  • nefgrixisnefgrixis Member ✭✭

    Even with the correct framework version it still doesn't want to update or install any packages that are version 26 and above

Sign In or Register to comment.