Yet another Custom Font thread

Hey guys,

I am trying to implement a custom font into my Xamarin forms app. The font is Quicksand-Regular from Google.

Checklist:
Font has been added at different points to Fonts/, the root directory , and the Resources folder.
The build action is set to BundleResource, and the output director has been tested with both Always Copy, and Do Not Copy.
The Plist has been amended with
UIAppFonts

Quicksand-Regular.tff

The useable name of the font is just Quicksand but I tried referencing it in the app with both Quicksand and Quicksand-Regular.
I have tried to add,



To the app wide resource dictionary, as well as refer directly to the font on a label, both just specifying the FontFamily and referring to it as platform specific.
The odd thing I'm seeing is that in the preview window it's working fine, both label and button text is being replaced correctly but this doesn't work runtime.

I believe then the resource isn't actually getting found or copied to the iOS project correctly but any suggestions would be appreciated.

Sign In or Register to comment.