Xamarin.Forms project is missing Mono.Android package.

Hello Guys, I had an old project which was working fine before. Now, I am getting following error. I have updated my packages for the newer build but still it is failing to build it successfully. From the error, it says, i am missing some package and I tried restoring but won't fix it. I am using Visual Studio for Mac restore process.

Error: This project references NuGet package(s) that are missing on this computer. Use NuGet Package Restore to download them. For more information, see http://go.microsoft.com/fwlink/?LinkID=322105. The missing file is ../../packages/Xamarin.Forms.2.3.3.175/build/portable-win+net45+wp80+win81+wpa81+MonoAndroid10+Xamarin.iOS10+xamarinmac20/Xamarin.Forms.targets. (Win)

Best Answer

Answers

  • mattwardmattward GBMember Xamurai

    I would look at the .csproj in the text editor for the line that has that import for Xamarin.Forms.2.3.3.175/build/portable-win+net45+wp80+win81+wpa81+MonoAndroid10+Xamarin.iOS10+xamarinmac20/Xamarin.Forms.target and see if there are other imports for Xamarin.Forms. I suspect that you are using a different Xamarin.Forms NuGet package version and there is an old import still in the project file which can be removed.

  • SunnyKhan.3452SunnyKhan.3452 USMember ✭✭

    Thanks for this. I tried above solutions suggested by you all. I am going from one issue to another one due to the updates. I have removed the xamarin.forms package from my solution and added it again. Now, I am getting another error saying:-

    /win/Win/Win.Droid/obj/Debug/library_projects/Xamarin.Android.Support.v7.AppCompat/library_project_imports/res/values-v26/values-v26.xml: Error APT0000: 1: error: Error: No resource found that matches the given name: attr 'android:keyboardNavigationCluster'. (APT0000) (Win.Droid)

    Can anyone suggest a fix for this one. It has become really tiresome job for me. I tried cleaning bin and obj folders but didn't work. May be due to other updates, the package Xamarin.Android.Support.v7.AppCompat is not compatible anymore with my project.

  • mattwardmattward GBMember Xamurai

    @SunnyKhan.3452 - There is a bug reported with a similar error. The problem there was that the Android SDK 26 was not installed.

Sign In or Register to comment.