Xamarin studio Invalid or Corrupt License

Whenever I try to build anything in Xamarin (since this morning, was working fine Friday), it claims my license is either invalid or corrupt and asks me to log in again. When I do, I get the following information and am told to contact Xamarin support:

System.NullReferenceException: Object reference not set to an instance of an object.
at Xamarin.Components.Ide.Activation.ActivationDialog.ErrorBody..ctor(Exception error)
at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step)
at Xamarin.Components.Ide.Activation.ActivationDialog.<>c__DisplayClass13.b__12(Task t)

A little help would be appreciated, thanks.

Posts

  • mhutchmhutch USMember, Xamarin Team Xamurai

    Xamarin.Android causes an incorrect activation error when API level 19 is installed. You can work around it by uninstalling API 19 from the Android SDK manager.

  • SharSinnaSharSinna GBMember

    Well that is annoying. Thanks very much for letting me know. Interesting thing to note, I installed the API on Friday, things didn't go bad until the next time I ran Xamarin. Not the next time I debugged; that was fine. Had to shut down and start it up again before it all went mammaries skyward. Hope that's some help.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    There's a persistent XA MSBuild process while XS is running, I expect it didn't recheck the installed APIs levels until you restarted XS.

  • SanthoshSanthosh USMember

    Whenever I try to build anything in Xamarin it shows Invalid or corrupt license with the following two erros
    C:\Program Files\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error XA0000: Could not determine $(TargetFrameworkVersion) for API level '19.' (XA0000) (helloworld)

    C:\Program Files\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error XA9010: Unable to determine license edition. (XA9010) (helloworld)

    and asks me to log in again. I couldn't fix the problem.. I have uninstalled and re install the Xamarin studio it shows the same problem. I have tried both starter and business edition.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Have you configured your project to use the Android v19 API?

  • mhutchmhutch USMember, Xamarin Team Xamurai

    Either use the Android SDK Manager to remove API 19, or use Xamarin.Android 4.10.2 from the beta channel.

  • SanthoshSanthosh USMember

    Now it works.... Thank so much Michael and Stedfast... :)

Sign In or Register to comment.