Xamarin Firebase Components Not Found

I have been working to get any of the Xamarin.Firebase components working in my project. Mainly Xamarin.Firebase.Auth and Xamarin.Firebase.Database .

At first my issues were dealing with target API levels. Even when installing the lowest available version of Xamarin.Firebase.Auth, it would error stating that it could not install Xamarin.Android.Support.v4 26.0.2 because my target framework was set to 5.0 (which is actually where I want it). Why is the lowest version targeting API level 26 support libraries? I am still having this issue with my original project, even after changing the target to 8.0 .

I started a brand new project, just to see if I could get the Firebase components that I wanted to install, and I finally did. However, after closing Visual Studio (or even just the solution) all of the components error and say that they are not found. (I tried to post a picture, but apparently I can't)

Could someone please help me out?

I would like to be able to use these components in my Xamarin project that targets Android 5.0. If there is no configuration that allows this, how can I fix the issue where the references break after closing and reopening the solution?

Thanks!

Tagged:

Answers

  • tuyenvtuyenv VNUniversity ✭✭✭

    Have you tried to install Firebase nuget packages?

Sign In or Register to comment.