FastRenderers cannot be extended

matt4pimatt4pi USMember

FastRenderers for Android have been changed from public classes to internal sealed classes to prevent people from overriding them (this commit: 25e5a25f6b9d7ec9f7ccb8d050b27dd4550005a2)

This causes issues for anyone with custom renderers who will not be able to extend from the FastRenderer based renderers to see the same performance benefits.

Given that anyone wanting to use the FastRenderer classes needs to enable the "FastRenderers_Experimental" flag, it would suggest that the developer is savvy enough to understand that "Experimental" suggests that the classes may change rapidly, and that breaking changes may occur going forward. Blocking the developer from being able to utilise FastRenderer benefits for custom renderers seems like overkill.

Let me know what you think.

Sign In or Register to comment.